Misleading wording describing severity "blocker" on Bugzilla Helper form

RESOLVED FIXED in Bugzilla 2.18

Status

()

defect
--
minor
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: bugzilla, Assigned: gerv)

Tracking

2.17.4
Bugzilla 2.18
Bug Flags:
approval +

Details

()

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030913 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030913 Firebird/0.6.1+

The Severity Option when filling out the Bugzilla Helper form describing a
"blocker" severity bug as one that "prevents you from testing or developing
Mozilla".

I don't know whether that an accurate description or not, but everywhere in
triaging and QAing bugs, "blocker" is treated as meaning 'prevents *mozilla.org
developers* from testing or developing Mozilla'.

Rewording the description on the helper form would stop people from labeling
bugs as blocker because it blocks their personal work, and then wondering why
the severity of their bug gets downgraded when they did what the form said. 
(Example: http://mecha.mozilla.org/show_bug.cgi?id=219642)

Reproducible: Always

Steps to Reproduce:
Bugzilla Helper -> Gerv
Assignee: endico → gerv
Posted patch Patch v.1Splinter Review
The man has a fair point. This changes the wording to "This bug prevents
Mozilla developers from testing or developing the software."

Gerv
Moving to Bugzilla product.

Gerv
Severity: enhancement → minor
Status: NEW → ASSIGNED
Component: Bugzilla: Other moz.org Issues → Creating/Changing Bugs
Product: mozilla.org → Bugzilla
Target Milestone: --- → Bugzilla 2.18
Version: other → 2.17.4
Comment on attachment 131803 [details] [diff] [review]
Patch v.1

Dave: could you rubber-stamp and then approve this wording change?

Gerv
Attachment #131803 - Flags: review?(justdave)
I don't know if it's suitable to include "Mozilla developers" in the
/mozilla/webtools/bugzilla/template/en/default directory. It contains the
default template, that will be the out-of-the-box thing for all new Bugzilla
installations.
Brainstorming idea to consider: how about leaving "developers", without Mozilla
in front?
That template is intentionally Moz-specific in lots of places, and is marked as
such. It's officially in the tree as an "example" :-)

Gerv
>> That template is intentionally Moz-specific in lots of places

I did

grep -R "Mozilla" * | grep -v "Public"

in the "bugzilla" directory in order to find references to Mozilla (excluding
"Mozilla Public License").

I found around 87 matches. The only template that I could find that is
specifically made for bugzilla.mozilla.org is create-guided.html.tmpl.
> The only template that I could find that is
> specifically made for bugzilla.mozilla.org is create-guided.html.tmpl.

Yep, that's right - it's currently the only template which is in the tree under
the "example" idea we thought up :-)

Gerv
Comment on attachment 131803 [details] [diff] [review]
Patch v.1

works for me.
Attachment #131803 - Flags: review?(justdave) → review+
Fixed.

Checking in template/en/default/bug/create/create-guided.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create-guided.html.tmpl,v
 <--  create-guided.html.tmpl
new revision: 1.13; previous revision: 1.12
done

Gerv
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
QA Contact: myk → default-qa
You need to log in before you can comment on or make changes to this bug.