The default bug view has changed. See this FAQ.

"OK" button doesn't activate in "Link Properties" dialog

RESOLVED FIXED

Status

MailNews Core
Composition
--
minor
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: Jerry Baker, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey1.1.5, verified1.8.1.8})

Trunk
x86
Windows XP
fixed-seamonkey1.1.5, verified1.8.1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.30 KB, patch
glazou
: review+
Scott MacGregor
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
2003091704 trunk

1. Open an HTML mail composition and insert a named anchor (Insert -> Named 
   Anchor).
2. Now, do Insert -> Link.
3. Select the named anchor from the dropdown FIRST, and then type in the text 
   for the link.

RESULT:
It is now IMPOSSIBLE to get the OK button to activate.

EXPECTED:
Activation of OK button should not depend on the order in which you complete fields.

Comment 1

13 years ago
xref bug 244020: same bug for Composer, except it doesn't matter whether text is 
entered first: selecting the anchor from a dropdown always prevents the OK 
button from enabling.
Product: MailNews → Core

Comment 2

11 years ago
*** Bug 350468 has been marked as a duplicate of this bug. ***

Comment 3

11 years ago
Created attachment 236543 [details] [diff] [review]
patch

The autocomplete part has worked because typing in the textbox to active autocomplete enables the button
Assignee: sspitzer → ajschult
Status: NEW → ASSIGNED
Attachment #236543 - Flags: superreview?(neil)
Attachment #236543 - Flags: review?(neil)
(Assignee)

Comment 4

11 years ago
Comment on attachment 236543 [details] [diff] [review]
patch

>   <textbox id="hrefInput" type="autocomplete"
>            searchSessions="history" timeout="50" maxrows="6"
>            disablehistory="false" class="uri-element"
>            oninput="ChangeLinkLocation();">
>     <menupopup class="autocomplete-history-popup"
>                popupalign="topleft" popupanchor="bottomleft"
>-               oncommand="this.parentNode.value = event.target.getAttribute('label');"/>
>+               oncommand="this.parentNode.value = event.target.getAttribute('label'); doEnabling()"/>
Why do you think we don't use oninput="doEnabling()"? Hint: there are two reasons, one logical, one of style.
Attachment #236543 - Flags: superreview?(neil)
Attachment #236543 - Flags: superreview-
Attachment #236543 - Flags: review?(neil)
Attachment #236543 - Flags: review-

Comment 5

10 years ago
It is very hard to find this bug based on the title of the big, even though that title is accurate.  I would describe this bug as "Problem inserting link in e-mail".  I'm entering this comment hoping that if others do a search on this problem this comment will make it more likely that people will find it and VOTE for it.  

The problem persist in Thunderbird 1.5 and 2.0.0.0

Comment 6

10 years ago
(In reply to comment #5) [fixed typo]
> It is very hard to find this bug based on the title of the bug, even though
> that title is accurate.  I would describe this bug as "Problem inserting link
> in e-mail".  I'm entering this comment hoping that if others do a search on
> this problem this comment will make it more likely that people will find it and
> VOTE for it.  
> 
> The problem persist in Thunderbird 1.5 and 2.0.0.0
> 

Updated

10 years ago
Duplicate of this bug: 317363

Comment 8

10 years ago
Contrary to the original report it is possible to get the OK button to activate.  It's unacceptable, of course, but a workaround nonetheless.

Copied from Bug 317363:
The user must edit the anchor name manually, either by typing the whole thing or by selecting the anchor from the list, then editing with the keyboard in any way.  For example, select it from the list, backspace over the last character, then type it back again.
(Assignee)

Comment 9

10 years ago
Created attachment 279905 [details] [diff] [review]
Fix broken function too

No wonder ajschult couldn't work out what my issue was - I'd accidentally broken the ChangeLinkLocation function so that it had the same effect as doEnabling :-( Line 251 contains the correct invocation, which I have copied.

Setting a textbox's value from script no longer triggers input events (bug 272002) so to fix this bug we have to call ChangeLinkLocation manually.
Assignee: ajschult → neil
Attachment #236543 - Attachment is obsolete: true
Attachment #279905 - Flags: review?(daniel)
Comment on attachment 279905 [details] [diff] [review]
Fix broken function too

r=me
Attachment #279905 - Flags: review?(daniel) → review+
(Assignee)

Updated

10 years ago
Attachment #279905 - Flags: superreview?(mscott)
Attachment #279905 - Flags: approval-thunderbird2?

Comment 11

10 years ago
Comment on attachment 279905 [details] [diff] [review]
Fix broken function too

switching to a 1.8.1.7 nomination flag. Low risk correctness patch that shouldn't effect Firefox.
Attachment #279905 - Flags: superreview?(mscott)
Attachment #279905 - Flags: superreview+
Attachment #279905 - Flags: approval1.8.1.7?
Attachment #279905 - Flags: approval-thunderbird2?
Comment on attachment 279905 [details] [diff] [review]
Fix broken function too

approved for 1.8.1.7, a=dveditz for release-drivers
Attachment #279905 - Flags: approval1.8.1.7? → approval1.8.1.7+
(Assignee)

Comment 13

10 years ago
Fix checked in to the branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed-seamonkey1.1.5, fixed1.8.1.7
Resolution: --- → FIXED
verified fixed 1.8.1.7 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.7pre) Gecko/20070910 Thunderbird/2.0.0.7pre Mnenhy/0.7.5.666 ID:2007091103

OK button works fine with the steps to reproduce from this bug. -> Adding verified keyword
Keywords: fixed1.8.1.7 → verified1.8.1.7
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.