Last Comment Bug 219821 - can't open a 'news:' URI in new tab/window (enable Open Link in New Tab/Window context menu entries for news URLs)
: can't open a 'news:' URI in new tab/window (enable Open Link in New Tab/Windo...
Status: RESOLVED FIXED
[bugday0420][SmBugEvent]
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.6
Assigned To: Ian Neal
:
Mentors:
news://news.mozilla.org:119/j8OdnddY9...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-20 15:43 PDT by David G King
Modified: 2011-09-05 14:46 PDT (History)
2 users (show)
iann_bugzilla: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
wontfix
fixed
fixed
fixed


Attachments
Remove disablement from nsContextMenu [Checked in: Comment 12 & Comment 14] (1.10 KB, patch)
2011-08-30 06:00 PDT, Ian Neal
neil: review+
bugspam.Callek: approval‑comm‑aurora+
bugspam.Callek: approval‑comm‑beta+
Details | Diff | Splinter Review

Description David G King 2003-09-20 15:43:16 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916

At the above URL, there is a link to
news://news.mozilla.org:119/3F6C68C1.8070206@mozilla.org
which I expected to be able to right-click and open in a new tab or window.
However, the resulting window didn't have either option. 

When I clicked on the link, it displayed the URI in the existing tab that I was
viewing Mozillazine in.

Reproducible: Always

Steps to Reproduce:
1. goto specified URL
2. try and open link to the 15/Sept staff meeting in a new tab/window.

Actual Results:  
Wrong menu appeared.

Expected Results:  
Ability to open news: link in new tab.

This is running 1.5 RC1
Comment 1 Robert Kaiser 2009-06-14 17:32:00 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 2 Tony Mechelynck [:tonymec] 2010-04-20 11:29:41 PDT
INVALID: you don't open "news" URLs in the browser
Comment 3 Tony Mechelynck [:tonymec] 2010-04-20 11:39:59 PDT
sorry, comment #2 was mistaken
Comment 4 Tony Mechelynck [:tonymec] 2010-04-20 11:41:41 PDT
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.10pre) Gecko/20100419 SeaMonkey/2.0.5pre - Build ID: 20100419001026

Confirming. No "Open in New Tab" in context menu
Comment 5 Tony Mechelynck [:tonymec] 2010-04-20 11:48:03 PDT
the URL in comment #0 opens a blank page for me: outdated URL?
Comment 6 Jens Hatlak (:InvisibleSmiley) 2010-04-20 11:52:21 PDT
(In reply to comment #5)
> the URL in comment #0 opens a blank page for me: outdated URL?

Probably. Put the one brought up on #bugday into the URL field.
Comment 7 Tony Mechelynck [:tonymec] 2011-05-18 14:04:53 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:2.0.2pre) Gecko/20110517 Firefox/4.0.2pre SeaMonkey/2.1.1pre

Still no "open in new tab/window" menuitems in context menu. Strangely enough, clicking the link opens it in a new _browser_ tab, not in the mailer and (unlike http links) not in the current browser tab.

A mailto: link has the same context menu (but clicking it opens a message-compose window, of course).
Comment 8 Ian Neal 2011-08-30 06:00:41 PDT
Created attachment 556812 [details] [diff] [review]
Remove disablement from nsContextMenu [Checked in: Comment 12 & Comment 14]

This was originally put in as part of the fix to bug 32359, as the browser now knows how to deal with news/snews, the news/snews part can be removed.
Comment 9 neil@parkwaycc.co.uk 2011-08-30 07:42:16 PDT
Comment on attachment 556812 [details] [diff] [review]
Remove disablement from nsContextMenu [Checked in: Comment 12 & Comment 14]

Does saving a news: link work? (I don't have an easy example to test.)
Comment 10 Ian Neal 2011-08-30 13:23:47 PDT
(In reply to neil@parkwaycc.co.uk from comment #9)
> Comment on attachment 556812 [details] [diff] [review]
> Remove disablement from nsContextMenu
> 
> Does saving a news: link work? (I don't have an easy example to test.)

It saves it as an email message e.g.
news://news.mozilla.org:119/j8OdnddY9vrWDlrWnZ2dnUVZ_vydnZ2d@mozilla.org
Comment 11 neil@parkwaycc.co.uk 2011-09-04 15:39:09 PDT
Comment on attachment 556812 [details] [diff] [review]
Remove disablement from nsContextMenu [Checked in: Comment 12 & Comment 14]

It might be an idea to rewrite this as a sequence of &&s using De Morgan's Law, which says that !(a == b || c == d) can be written a != b && c != d. [Would lose the blame for this.linkProtocol == "mailto" though ;-) ]
Comment 12 Ian Neal 2011-09-05 05:15:32 PDT
Comment on attachment 556812 [details] [diff] [review]
Remove disablement from nsContextMenu [Checked in: Comment 12 & Comment 14]

Checked in with suggested change:
http://hg.mozilla.org/comm-central/rev/9eba3b1b217b
Comment 13 Ian Neal 2011-09-05 05:17:50 PDT
Comment on attachment 556812 [details] [diff] [review]
Remove disablement from nsContextMenu [Checked in: Comment 12 & Comment 14]

This low risk, simple fix should be ideal to go into both comm-aurora/beta

Note You need to log in before you can comment on or make changes to this bug.