[10.1] all bookmarks are lost when camino is quit

RESOLVED FIXED in Camino0.8

Status

Camino Graveyard
Bookmarks
--
critical
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Xavier Snelgrove, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino0.8
PowerPC
Mac OS X

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030917 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030917 Camino/0.7+

If you quit Camino, all the bookmarks are deleted, and it reverts to the default
set.

Reproducible: Always

Steps to Reproduce:
1.Add some bookmarks
2.quit Camino
3.Reopen Camino

Actual Results:  
The added bookmarks were gone

Expected Results:  
they should have stayed

Comment 1

15 years ago
Unable to reproduce with the 2003091702 NB. Does this still happen if you use a fresh profile?
(Assignee)

Comment 2

15 years ago
where is your home dir? on a networked server?
(Reporter)

Comment 3

15 years ago
The problem came when I downloaded one build, and it just showed up as a
directory. I had to wait for the next build to download a working version, and
since then it's been acting screwy.

I am not using a networked home directory.

The problem exists for all the users on my computer, and they each have their
own homes, so I don't see how the profile would fix it.
(Assignee)

Comment 4

15 years ago
if it happened when you started a particular version, can you go back to a
certain date build and have it work again? that would help us narrow down the
problem.

Comment 5

15 years ago
I had the same problem when I downloaded 1.5rc1 and 1.5rc2 of Mozilla for Mac
OS.  When I went back to 1.4, the bookmarks no longer disappeared.  It almost
always happens, but not 100% of the time.  I'm using OS 10.1.5 -- don't know if
that is related to the problem.
(Reporter)

Comment 6

15 years ago
I too am using 10.1.5, which might be part of the problem. I'm not sure where to
go to download outdated nightly builds, except of course for the milestone
build. Is that one good enough?

Comment 7

15 years ago
I hope this helps.

Build ID 2003082702 puts down "bookmarks.xml" into my profile.
Build ID 2003100911 removes "bookmarks.xml", and writes "_bookmarks_temp.bak".

As far as I can tell, all builds after 2003082702 do this on my two machines.
Both are running 10.1.5 . One is a Quicksilver G4, the other is a 2001 iBook.

This happens consistently with any build after 2003082702 (on my machines):
  1.  Install new build
  2.  Launch new build
  3.  New build finds current bookmarks
  4.  When I quit new build, it overwrites the .xml file, with the .bak file
  5.  The new .bak file always has the default bookmarks.
  6.  If I delete (or change/add) any bookmarks, the changes
      are lost once quit, and relaunched.

Anyway, I have been sitting on build #2003082702 since I notitced this prob,
hope this info helps. I would like to help my favourite browser along! Well done
everyone...  

PS: please excuse any etiquette slips - I am not certain if I am supposed to
change the status or anything.

Comment 8

15 years ago
I've had this same problem. I'm currently running a 2003070404 build of Camino
on Mac OS X 10.1.5. I'd upgraded in September to a newer nightly build and
pretty consistently lost my booksmarks. The one odd this about my setup is that
I have my home directory on a seperate partition of my hard drive. Could that be
the culprit?

Comment 9

15 years ago
Mac OS 10.1.5 Recent builds eg: 20031009

I have the same bug going on with my computer.  David, it doesn't seem to be a
partition problem since I've installed it both ways (on same partition as
"home"/ on different partition) and get the same disappearing new bookmarks (and
revert to defaults) problem each time the camino program is quit and restarted.
 I've decided to stay with 20030306 (which keeps my bookmarks) until the problem
gets fixed.

BTW--I suggest copying and saving your bookmarks file in another directory every
so often.  It really sucks losing all the bookmarks you've collected over the
last few months.
(Assignee)

Comment 10

15 years ago
can we confirm that this also happens in mozilla? if so, we need to kick it over
there and make the person responsible fix the regression. i think we can
probably pin down the problem to the xml parser changes in early september
(iirc) if we try hard enough.

Comment 11

15 years ago
Current builds of Mozilla have a similar problem but do not revert back to a
default bookmark set.  It may just be that there is no backup file for the
bookmarks to revert to.  I am unsure how it works.  Mozilla seems to delete the
bookmarks.html file on quit and then it is impossible to add bookmarks to the
toolbar.  This does not happen with Camino but there may be fail-safes build
into Camino that I don't understand.  

For similar bookmark disappearance I suggest:
http://bugzilla.mozilla.org/show_bug.cgi?id=221037

I do not know if these problems are the same or at least linked.  I leave this
up to others.
(Assignee)

Comment 12

15 years ago
sounds like it's a problem on the mozilla end, but should fix for the 10.1
crowd. unfortunately, i don't have any access to a 10.1 machine.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: all bookmarks are lost when camino is quit → [10.1] all bookmarks are lost when camino is quit
Target Milestone: --- → Camino0.8

Comment 13

15 years ago
Does the recent patch for 221843 fix this bug? I don't have 10.1 to test and the
descriptions look like they overlap nicely.
(Reporter)

Comment 14

15 years ago
Sorry, I'm running 10.3 now so I can't test in 10.1 any longer, but the bug is
not an issue in 10.3 for me.
(Assignee)

Comment 15

15 years ago
pat can you confirm this is fixed? i'm gonna mark it fixed, please reopen if it
is still a problem.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 16

15 years ago
Sorry it took me so long to get back to you.  I'm away on Winter vaccation.  It
works! My bookmarks are staying yay! (At least so far.) Was it a Mozilla side
problem or a Camino one?
You need to log in before you can comment on or make changes to this bug.