Navigator->Languages for Web Pages empty, wrong character coding

VERIFIED FIXED

Status

Core Graveyard
Embedding: GRE Core
--
major
VERIFIED FIXED
14 years ago
a year ago

People

(Reporter: Hermann Schwab, Assigned: Benjamin Smedberg)

Tracking

({regression})

Trunk
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: win32 installer builds only)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
When I opened preferences, I saw no Languages for Web Pages, and default
Character Coding set to Arabic (IBM-864)
I then checked with http://www.gemal.dk/browserspy/accept.cgi that my prefs were
transmitted like before.
View-> Character Coding was correctly showing my Western (ISO-8859-1).
So it seems my prefs are ok, but not shown.

I then started a 1.5 Mozilla with another profile, default language only, and it
was shown in prefs and gemals website.
I then switched the 1.5 Mozilla to my default profile, with all my languages,
and they were shown in prefs and gemals website.
Also Character Coding was my default ISO-8859-1.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20030923
ok: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030915
(Reporter)

Comment 1

14 years ago
Regressed between 2003091209 (working) and 2003091604 (failing)
I didn´t download the only win32 nightly inbetween, 2003-09-15-10-trunk, as I´m
on ISDN only.
Keywords: regression
if this works in tomorrows build (and it works in my cvs from 20030923.. !),
please mark it as dupe of bug 219456 (don't look at the summary, it affects all
prefs)

And please reread the component description for your selected component.
(Reporter)

Comment 3

14 years ago
My prefs are seen by Gemal´s website, and every other site in the internet, but
not by me in my prefs window.
Which Component would you recommend, Matti?
(Reporter)

Comment 4

14 years ago
Regressed between 2003091209 (working) and 2003091510 (failing)
still failing: BuildID 2003092404
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20030924

first seen with BuildID 2003091510 on Win98SE, now on BuildID 2003092404
can´t c&p the UA from about: as I get an XML error displayed.

I created a test profile, tried to change the language, but got no selection
offered. I selected another character coding, but it wasn´t saved. 
(Reporter)

Comment 5

14 years ago
Build ID: 2003092504 still failing, Win98SE
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20030925
(Reporter)

Comment 6

14 years ago
Build ID: 2003092604 still failing, Win98
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20030926
(Reporter)

Comment 7

14 years ago
*** Bug 221281 has been marked as a duplicate of this bug. ***
Do you tested a new profile and is that a clean install ?
(Reporter)

Comment 9

14 years ago
Matti, as seen in comment 4, I did a clean install, created a new profile just
for  testing this, tested with different versions of mozilla, and did these
tests on Win98 on my machine at home and Win98SE at work.
Using my standard profile, this bug shows up in newer versions, and not in older
versions.
I did the regression test using the same profile, installing different builds.
In comment #1 I tested at home on Win98:
Regressed between 2003091209 (working) and 2003091604 (failing)
in comment #4 I tested at work on Win98SE:
Regressed between 2003091209 (working) and 2003091510 (failing

When I´m doing regression test, I always use a new profile, mostly the same for
the series of tests.

If you have suggestions whatelse to test, feel free to sent mail.
I´m using installer-sea.exe, and have multiple releases in separate folders,
having own profiles. But sometimes I also use them with my default or my default
test profile. If I want to isolate a bug, I use a freshly created profile.
Could the bug be in registry.dat? 
Sorry i missed your comment. The reason for my question is that I can't reprduce
this on my system..
(Reporter)

Comment 11

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031004
created new profile, started Javascript console, opened preferences, navigator
When I opened languages, the console showed the error:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIStringBundle.getSimpleEnumeration]" 
nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://communicator/content/pref/pref-languages.js :: ReadAvailableLanguages
:: line 126"  data: no]

reproducable, tested in a new and my default profile for daily use.

OS is win98SE.
(Reporter)

Comment 12

14 years ago
TB24169756M with 1.5RC2, seems to have problem fixed.

I started 1.6a and got same results as above in comment 11, this time on another
computer running Win98, not Win98SE.
Terminated session, to start 1.5RC2 from a windows shortcut.
Shortcut (with argument -ProfileManager) was broken, as I had installed into a
fresh directory, with another name, so I used the Browse button in the Windows
errormessage, to select the directory. Browser started without argument, and
shortcut was repaired afterwards.
Think I got same errormessage as above, as it used my default directory.
I used Tools->SwitchProfile to create a new directory, and this time also used
the Select Region button before finishing the profile.
Profile started, Edit->Preferences->Navigator->Languages was showing one or two
languages, don´t remember.
Then I wanted to return to my default profile, to retest.
When I opened the languages pref, Mozilla crashed, and I sent Talkback above.
I restarted Mozilla, checked again, and now the pref is showing all my languages

JS console only shows 
Warning: reference to undefined property this.mPanelContainer
Source File: chrome://global/content/bindings/tabbrowser.xml
Line: 1420
but that is another problem.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030925
(Reporter)

Comment 13

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031004

Crash without Talkback coming up, only DocWatson was seen.
I started the browser with my default profile, which had shown my 4 languages
with 1.5 in the comment before. No laguages seen, so I switched profile and
created a fresh one, also selecting a region. No language seen.
The I switched to the 1.5RC2 profile just created (no extensions, passwords,
cookies, only the profile created by profile manager), couldn´t see languages.
Than used Tools-switchProfile again to return to my default profile.
When I opened the language pref, mozilla crashed with DocWatson coming up, but
no Talkback.
(Reporter)

Comment 14

14 years ago
bug still there, further testing done:
BuildID 2003100711:
deleted localstore.rdf, panels.rdf, downloads.rdf, started Mozilla, bug seen
deleted XUL.mfl: bug still seen
saved/deleted prefs.js: default prefs was created, bug still seen.
restored prefs.js.

I´ve multiple mozilla installed, mostly started with their own profile.
With mozilla 1.5 I checked the 1.5 profile: ok, then trunk profile: ok
Then with Trunk I checked the trunk Profile: bug, then the 1.5 profile: bug.

Installed todays 1.5, ok:
http://ftp.mozilla.org/pub/mozilla/nightly/latest-1.5/mozilla-win32-installer-sea.exe

Couldn´t deinstall Trunk, so I renamed it´s folder, and installed trunk:
http://ftp.mozilla.org/pub/mozilla/nightly/2003-10-08-04-trunk/mozilla-win32-installer-sea.exe
Bug still seen
I could deinstall trunk now, deinstalled, and reinstalled with a new, never used
folder name, bug still seen.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031008

Starting JS-console gives following error:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIStringBundle.getSimpleEnumeration]" 
nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://communicator/content/pref/pref-languages.js :: ReadAvailableLanguages
:: line 126"  data: no]

Whatelse can I do? LXR gives:

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpfe/components/prefwindow/resources/content/pref-languages.js

var acceptedBundleEnum = acceptedBundle.getSimpleEnumeration();

Bug 170514 Language name representation not localisable


Looking for checkins in the regression timeframe:
Regressed between 2003091209 (working) and 2003091510 (failing)

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=mozilla%2F&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=09%2F12%2F2003&maxdate=09%2F16%2F2003&cvsroot=%2Fcvsroot

I don´t know whatelse to do, anybody any idea?
(Reporter)

Comment 15

14 years ago
renamed my registry.dat while browsing ( so no profiles would be lost ),
closed mozilla, restarted mozilla, and a new registry.dat was created, bug still
seen. Closed browser, deleted it, and restored the old one, to get back all the
other profiles.

to summarize:
installing in new folder, and creating a new profile at start didn´t help
deleting of rdf and registry.dat didn´t help, deleted all languages with 1.5
didn´t help, recreating the languages with 1.5 didn´t help.
1.5 sees the data in all profiles, 1.6 in none.

now on another computer, running win98.
same as above, new try:
Installed Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031008
from ZIP, into a new folder with never used name, and started via shortlink
calling ProfileManager. I created a new profile, ok, added languages, ok,
switched to the old profile, all languages seen.

Installed Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031008
from SEA-EXE, into a new folder with never used name, and used ProfileManager
right at start to create a new profile with never used name. No languages seen,
couldn´t added languages, switched to the old profile, no languages seen.

Back to the zip build, and writing this comment.
(Reporter)

Comment 16

14 years ago
raised the blocking 1.6a flag to get some attention

summarizing: 
Regression, worked in Build ID 2003091209 and failed in next Build ID 2003091510.
Extensively tested on two computers running Win98 and Win98SE, read the comments.
Not seen in (latest) 1.5, latest trunk ZIP, but seen in trunk SEA-EXE.
Can´t see or modify, add, remove languages. Charcode can be selected, but
doesn´t get saved, or sent to a website. Old data unchanged in the profile, as
seen with other mozillas.

Javascript console, reproducable:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIStringBundle.getSimpleEnumeration]" 
nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://communicator/content/pref/pref-languages.js :: ReadAvailableLanguages
:: line 126"  data: no]

links to LXR and bonsai queries for the regression period in comment 14
Severity: normal → major
Flags: blocking1.6a?
(Reporter)

Comment 17

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031009
Used net installer:
http://ftp.mozilla.org/pub/mozilla/nightly/2003-10-09-04-trunk/mozilla-win32-installer.exe

Seen 18 x in JSconsole after starting Mozilla:
Warning: reference to undefined property this.mPanelContainer
Source File: chrome://global/content/bindings/tabbrowser.xml
Line: 1420

When opening Navigator->Languages
Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIStringBundle.getSimpleEnumeration]" 
nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://communicator/content/pref/pref-languages.js :: ReadAvailableLanguages
:: line 126"  data: no]
(Reporter)

Comment 18

14 years ago
Properties files are missing in /mozilla/res/

Bug still seen in Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031014
if installed from exe. Found that /mozilla/res doesn´t have the propertie files
found in the corresponding folder of a zip-install.
Copied charsetalias.properties, charsetData.properties, langGroups.properties,
language.properties, from the zip -install, restarted Mozilla, and it was working.
Also copied viewer.properties and wincharset.properties.

from comment #4:
Regressed between 2003091209 (working) and 2003091510 (failing)

Comment 19

14 years ago
Confirm bug with 2003101304 on win95 with importing from NS4.

Hermann looks like this haven't to do with bug 222101
(Assignee)

Comment 20

14 years ago
My bug, fallout from bug 179834... the .properties files have been moved into
the GRE, and I overlooked these references. The new URI is
resource://gre/res/language.properties. Is pref-languages.js the only file that
is affected here?
Assignee: bugs → bsmedberg
Component: Preferences → Embedding: GRE Core
Whiteboard: win32 installer builds only
(Assignee)

Comment 21

14 years ago
Created attachment 133277 [details] [diff] [review]
use resource://gre
(Assignee)

Comment 22

14 years ago
Comment on attachment 133277 [details] [diff] [review]
use resource://gre

Looking for a super-quick rs=
Attachment #133277 - Flags: superreview?(darin)
Attachment #133277 - Flags: review?(darin)
(Reporter)

Comment 23

14 years ago
the patch:
   if (!regionsBundle)    regionsBundle   =
srGetStrBundle("chrome://global/locale/regionNames.properties");
   if (!languagesBundle)  languagesBundle =
srGetStrBundle("chrome://global/locale/languageNames.properties");
   if (!prefLangBundle)  prefLangBundle =
srGetStrBundle("chrome://communicator/locale/pref/pref-languages.properties");
-  if (!acceptedBundle)   acceptedBundle  =
srGetStrBundle("resource:/res/language.properties");
+  if (!acceptedBundle)   acceptedBundle  =
srGetStrBundle("resource://gre/res/language.properties");

I´ve tested the URIs? before I found I could solve the problem by copying the
properties files.
The chrome links gave me a display, the resource:/res/language.properties didn´t
show a reaction, no display, no error message.
I noticed the resource:/res and tried a resource://res, to no avail.
after copying the propertie files to mozilla/res,
resource:/res/language.properties got displayed as
resource:///res/language.properties

So to me it seems you simply replace a / by //, and that didn´t work for me in
the location bar. Is the resolving of this link in the file different?
Or is some more patch needed?
(Reporter)

Comment 24

14 years ago
Forget my last comment.
I just noticed, that you replaced resource:/res/ with resource://gre/res/
and that is done like in the patches of your bug 179834,
but it didn´t work for me, as I´ve copied  the properties files into my res
directory. Read something about two tier approach, seems I got to reinstall
mozilla to test (or delete the copied files), but I can wait for the checkin,
wouldn´t take much longer as this bug, I hope.

Updated

14 years ago
Attachment #133277 - Flags: superreview?(darin)
Attachment #133277 - Flags: superreview+
Attachment #133277 - Flags: review?(darin)
Attachment #133277 - Flags: review+
(Assignee)

Comment 25

14 years ago
fixed on trunk. Could someone download an installer build tomorrow morning and
test if this fixes things, then mark the bug VERIFIED?
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 26

14 years ago
verified fixed: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031016
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.