Feedback Center! not accessible from the Help menu - may result in data loss

VERIFIED FIXED in M14

Status

SeaMonkey
Help Documentation
P3
major
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: rudman, Assigned: matt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
Using Build 19991212.
Choose Release Notes from the Help menu. Nothing happens.

The notes are accessible from the browser. Someone needs to hook up the
appropriate URL to the Release Notes item.

Updated

19 years ago
QA Contact: lchiang → nbaca

Updated

19 years ago
Assignee: phil → hangas

Comment 1

19 years ago
Reassign to hangas

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Updated

19 years ago
Target Milestone: M13 → M15

Comment 2

19 years ago
Bumping to M15

Comment 3

19 years ago
Then, should we put a "." before the menu item since M15 is past beta 1?
(Reporter)

Comment 4

19 years ago
The Release Notes are now accessible. BUT, I'm not sure it's expected
behavior---the notes display in the text field for messages. In 4.x, choosing
Release Notes while in Messenger meant the notes would display in the browser
window. A new browser window would be spawned if none was open. In Mozilla Mail,
the notes appear in the space where email text would appear. If you have a
message open already, the notes will appear below the header info
(Subject/Date/From/To fields) of the message. To get back to the message itself,
you can't double-click it---you have to leave the message altogether and return.
Not a very good user experience.

So, the bug is no longer that the notes don't appear, but they appear in a
strange spot.

The current build points to the M10 notes. The Release Notes item should point
to the M13 URL (filed as a separate bug for the browser---I assume the URL is in
a global XUL file).
(Reporter)

Comment 5

19 years ago
Not sure if there is a dupe bug for this. A similar bug for Composer (no
external browser for Help display) is
http://bugzilla.mozilla.org/show_bug.cgi?id=20291.
(Reporter)

Comment 6

19 years ago
This bug can result in the loss of user data. Can the TFV be changed to M14, as
is the case for 20291? (Though if the fix is a global one, then presumably a
change for 20291 will fix this bug.)
To see how user data can be lost, choose New Msg in Mail. Type something in the
message compose box. Choose either About or Release Notes from the Help menu.
Both items display in the compose box, and obliterate any text already there.

Comment 7

19 years ago
Build 2000-02-07-08M14: NT4, Linux 6.0, Mac 8.5.1

Changing Summary from "Release Notes not accessible from the Help menu" to 
"Feedback Please! not accessible from the Help menu". Can this be fixed for M14 
because of data loss issue otherwise I would recommend disabling the menu item 
from Mail Compose.

1. Help|Release Notes now opens a new Browser window and displays a Release 
Notes page, which is good.
2. Help|Feedback Please!
  - Does nothing when launched from the Mail 3-pane
  - Does nothing when launched from the Address Book
  - Overwrites the window contents from Mail Composer, data loss!

3. Help|About does nothing but this is reported in bug# 27015.

Additional Information: 
- All the Help menu items work when accessed from the Browser.
Severity: normal → major
Summary: Release Notes not accessible from the Help menu → Feedback Please! not accessible from the Help menu
(Reporter)

Comment 8

19 years ago
As Ninoschka indicates, choosing Feedback can result in data loss. I can just 
imagine what kind of feedback we'd get if that happened.

Nominating for PDT radar (beta1).
Keywords: beta1

Updated

19 years ago
Summary: Feedback Please! not accessible from the Help menu → Feedback Please! not accessible from the Help menu - may result in data loss

Comment 9

19 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]

Comment 10

19 years ago
the problem is in ns/ xpfe/ global/ resources/ content/ helpMenu.xul

part of a line in there is something like:

   oncommand="window.content.location.href='http://client/seamonkey/beta...



Instead the line should look something like:

  oncommand="goHelpMenu('http://www.mozilla.org/...



Also related to this bug is that the url is not external yet.  I assume that this 

is a known issue as well.

Component: Front End → Help
OS: other → All
Product: MailNews → Browser
Hardware: PC → All

Comment 11

19 years ago
Moving to M14 to be on MY radar now that this is PDT+
Target Milestone: M15 → M14

Comment 12

19 years ago
Estimating 2/18 for this bug.
Whiteboard: [PDT+] → [PDT+] 2/18

Comment 13

19 years ago
Sending to matt since he told me he was doing this helm menu work.
Assignee: hangas → matt
Status: ASSIGNED → NEW
Whiteboard: [PDT+] 2/18 → [PDT+]
(Assignee)

Comment 14

19 years ago
I have a fix for this in my tree.
Status: NEW → ASSIGNED
(Assignee)

Comment 15

19 years ago
fixed
open mail and composer
close browser window
open help menu and about:
should open new window
also if there is a browser window should open top level window
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 16

19 years ago
Mozilla Build 2000-02-16-09M14: NT4
Build 2000-02-16-08M14: Linux, Mac
Reopening. Data loss problem is fixed but focus problems exist.

It appears that the Help menu has changed. Instead of the menu item being 
"Feedback Please1" it appears to be called "Feedback Center".

For the 3-pane and Mail/Composer windows:
1. With the browser closed: From Mail selecting Help|Feedback Center opens the 
browser and gives it focus. It also displays the Feedback Center content.

2. With the browser open: In Mail I select Help|Feedback center, it doesn't 
necessarily bring the Browser to the forefront. Sometimes this works and other 
times it doesn't.  I've tried:

- Hiding the Browser window completely behind the 3-pane or Mail/Composer 
window.
- Exposing some of the Browser window with the 3-pane or Mail/Composer in the 
forefront.

Note: It seems to always work on the Mac from the 3-pane.

3. When Mail/Composer is open, the Help|Feedback Center menu item or any other 
menu item no longer places its information into the body of the message. This is 
great, no more data loss!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 17

19 years ago
This is supposed to the feedback center.
It's in the new UI
http://twain.mcom.com/client/infodsgn/browser/helpmenu/helpmenu.html#beta

1. File new bug for m15 for other problems.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
Summary: Feedback Please! not accessible from the Help menu - may result in data loss → Feedback Center! not accessible from the Help menu - may result in data loss

Comment 18

19 years ago
Verified Fixed. I will log a bug on the focus issue.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.