browser crash when its try to open the flash plugins [@ PlatformBitBuffer::CreateScreenBits ]

RESOLVED DUPLICATE of bug 200829

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED DUPLICATE of bug 200829
15 years ago
2 years ago

People

(Reporter: Eduardo Soares, Assigned: Peter Lubczynski)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.4) Gecko/20030624

In the page www.flash.com the flash plugins causes a crash. I´m using an
Exported X display with a video card Trident TGUI9680-1. I´m using the 6.0.79
version of flash plugin.

Reproducible: Always

Steps to Reproduce:
1.open www.flash.com
2.it crashes

Actual Results:  
mozilla crashes

Expected Results:  
open the flash plugin

[piau@aquario piau]$ /usr/lib/mozilla/mozilla --syn --no-xshm --debug
/usr/lib/mozilla/run-mozilla.sh -g /usr/lib/mozilla/mozilla-bin --syn --no-xshm
MOZILLA_FIVE_HOME=/usr/lib/mozilla
 
LD_LIBRARY_PATH=/usr/lib/mozilla:/usr/lib/mozilla/plugins:/usr/local/lib/mre/mre-1.4
DISPLAY=192.168.1.188:0.0
FONTCONFIG_PATH=/etc/fonts:/usr/lib/mozilla/res/Xft
DYLD_LIBRARY_PATH=/usr/lib/mozilla:/usr/local/lib/mre/mre-1.4
    
LIBRARY_PATH=/usr/lib/mozilla:/usr/lib/mozilla/components:/usr/local/lib/mre/mre-1.4
       SHLIB_PATH=/usr/lib/mozilla:/usr/local/lib/mre/mre-1.4
          LIBPATH=/usr/lib/mozilla:/usr/local/lib/mre/mre-1.4
       ADDON_PATH=/usr/lib/mozilla
      [piau@aquario piau]$ /usr/lib/mozilla/mozilla --syn --no-xshm --debug
/usr/lib/mozilla/run-mozilla.sh -g /usr/lib/mozilla/mozilla-bin --syn --no-xshm
MOZILLA_FIVE_HOME=/usr/lib/mozilla
 
LD_LIBRARY_PATH=/usr/lib/mozilla:/usr/lib/mozilla/plugins:/usr/local/lib/mre/mre-1.4
DISPLAY=192.168.1.188:0.0
FONTCONFIG_PATH=/etc/fonts:/usr/lib/mozilla/res/Xft
DYLD_LIBRARY_PATH=/usr/lib/mozilla:/usr/local/lib/mre/mre-1.4
    
LIBRARY_PATH=/usr/lib/mozilla:/usr/lib/mozilla/components:/usr/local/lib/mre/mre-1.4
       SHLIB_PATH=/usr/lib/mozilla:/usr/local/lib/mre/mre-1.4
          LIBPATH=/usr/lib/mozilla:/usr/local/lib/mre/mre-1.4
       ADDON_PATH=/usr/lib/mozilla
      MOZ_PROGRAM=/usr/lib/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
which: no ddd in
(:/bin:/usr/bin:/usr/X11R6/bin:/usr/ucb:/usr/local/bin:/usr/games:/home/piau/bin)
/usr/bin/gdb /usr/lib/mozilla/mozilla-bin -x /tmp/mozargs4782
GNU gdb 5.3-22mdk (Mandrake Linux)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-mandrake-linux-gnu"...
(no debugging symbols found)...
(gdb) 
(gdb) run
Starting program: /usr/lib/mozilla/mozilla-bin --syn --no-xshm
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 16384 (LWP 4926)]
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 32769 (LWP 5281)]
[New Thread 16386 (LWP 5282)]
[New Thread 32771 (LWP 5283)]
[New Thread 49156 (LWP 5576)]
[New Thread 65541 (LWP 5579)]
[New Thread 81926 (LWP 5602)]
[New Thread 98311 (LWP 5603)]
[New Thread 114696 (LWP 5604)]
[New Thread 131081 (LWP 5605)]
[New Thread 147466 (LWP 5606)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 4926)]
0x427e006d in PlatformBitBuffer::CreateScreenBits ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
(gdb) quit
The program is running.  Exit anyway? (y or n) y
[piau@aquario piau]$

Comment 1

15 years ago
WFM 20030923 PC/Win2K, Flash 6
Keywords: crash
That's the flash plugin itself crashing, not Mozilla....
(Reporter)

Comment 3

15 years ago
When I change the video card to a faster one, like a S3 trio 64+, the flash
plugin works fine. But the old card, TGUI9860, was working well and only craches
at flash  plugin.

Comment 4

14 years ago
The 15-bit issue is fixed with Flash 7, please reopen if still crashing with
Flash 7.

*** This bug has been marked as a duplicate of 200829 ***
Blocks: 211213
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: browser crash when its try to open the flash plugins → browser crash when its try to open the flash plugins [@ PlatformBitBuffer::CreateScreenBits ]

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: bmartin → adobe-flash
Target Milestone: --- → 2004
Version: Trunk → 6.x
Crash Signature: [@ PlatformBitBuffer::CreateScreenBits ]

Comment 5

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: 2004 → ---
Version: 6.x → unspecified
You need to log in before you can comment on or make changes to this bug.