Import/Export of mail files/address books/preferences between platforms is fatally flawed.

RESOLVED DUPLICATE of bug 22689

Status

enhancement
RESOLVED DUPLICATE of bug 22689
16 years ago
11 years ago

People

(Reporter: joe, Assigned: cavin)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030916

I have occasion to install Mozilla on a variety of platforms including
Win98/200/XP?NT.  Sometimes I install a new system on an XP machine and import
his old files from (say) OE or more frequently from an old NetScape version. 
The the user is unhappy and wants his old (say) Windows 98 back.  

If any of you have tried to move mail/address book/bookmark/preference file
around between platforms, you know what a TREMENDOUS HEADACHE it is even if you
have done it a number of times.  What we need is a REAL import/export mechanism
which can be used to shift the user profiles between various netscape and OE
versions and Mozilla.  As it is,  each such shift can involve several hours of
tweaking and adjustment and sometimes I make a misstep and lose some important
mail or other file.  

Reproducible: Always

Steps to Reproduce:
1.Just try to move mail from Mozilla Win2K platform to Win98 platform.
2. Just try and move mail/address book/bookmarks from Mozilla to OE!! very messy!
3. Just try and move Mozilla Win98 profiles to XP platform.

Actual Results:  
Can be done but is very time consuming and prone to error due to the manual
operations involved.

Expected Results:  
Have a routine in Mozilla able to do a reasonable job of profile transfer to
other platforms.

Comment 1

16 years ago
neglecting the "move ... from Mozilla to OE," this is a dupe.  In fact, there
are all sorts of bugs concerning export of this or that combination of stuff
(surprising that you didn't find them when searching for duplicates).  Most
relevant seems to be bug 22689 - import/export profile.

*** This bug has been marked as a duplicate of 22689 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.