ctrl left mouse click loading link in current tab

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: Jim Wilson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

When you use the ctrl left mouse click to load a link in a new tab it also loads
that link in the current tab. You do get the new tab, but you also get the
contents of the link in the current one. Try the above URL and ctrl left mouse
on any one of the listed forums.

Reproducible: Always

Steps to Reproduce:
1.ctrl left mouse click on any form link
2.
3.

Actual Results:  
A new tab was created and it loaded the selected link, but the current tab
loaded the same link.

Expected Results:  
Left the page in the current tab alone.
(Reporter)

Comment 1

14 years ago
I should have mentioned that right click, open link in new tab, works just fine.

Comment 2

14 years ago
This is because the <tr> has an onClick associated with it, which loads that
link in the current page (via javaScript) and the link is also opened in the new
tab.

I have marked this as depends on 217262 since the issue is the same... what to
do with onClick events when ctrl-clicking.

Moving to Browser: Tabbed Browser.

Setting severity: minor
easy workaround (right click -> open link in new tab)
Assignee: blake → jag
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: General → Tabbed Browser
Depends on: 217262
Ever confirmed: true
OS: Windows 2000 → All
Product: Firebird → Browser
QA Contact: pmac
Hardware: PC → All
Version: unspecified → Trunk
(Assignee)

Updated

14 years ago
Product: Core → SeaMonkey
Assignee: jag → nobody
QA Contact: pmac → tabbed-browser

Comment 3

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 4

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2

Ctrl+click on link in Seamonkey will open link in new window (which is by design, I suppose?)
Ctrl+click does not touch the current page any more, so this works.
--> worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.