If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Accessing an internal link (fragment identifier) residing within a block with overflow: hidden does not scroll the block to make the anchor visible

RESOLVED DUPLICATE of bug 69355

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 69355
14 years ago
13 years ago

People

(Reporter: Martin Jericho, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

If an internal document reference (<a name="bla"></a>) resides in a block with 
the style overflow:hidden, and the reference is outside of the visible area, 
clicking on a link that accesses this reference (<a href="#bla">link</a>) 
should scroll the block so that the reference is visible.

See the sample URL for a demonstration.

Reproducible: Always

Steps to Reproduce:

Actual Results:  
Nothing happens when link is clicked

Expected Results:  
referenced part of the document should become visible.

Comment 1

14 years ago
works for me 20030924 PC/WinXP
trying ->Layout
Assignee: general → other
Component: Browser-General → Layout
QA Contact: general → ian
Fixed on the 1.6a trunk by the checkin for bug 69355 

*** This bug has been marked as a duplicate of 69355 ***

*** This bug has been marked as a duplicate of 69355 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Layout → Browser-General
QA Contact: ian → general
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.