If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XSLT font problem taiwan, japanese

RESOLVED FIXED

Status

()

Core
XSLT
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: rnorberg, Assigned: peterv)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (OS/2; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030910

XSLT font problem ontaiwain, and japanese
Testcase : http://ei4b.test.austin.ibm.com/BrwTestXSLT/BrwTestXSLT.html    
Build ID : 20030904 and 20030910
Contact : Russell
Platform : fj4c k:\ MCP2

Actual Results:
 Open browser, go to "1.1 Test rendering of XSLT-generated text".
 Open the .xml and .html files in different tabs.
    http://ei4b.test.austin.ibm.com/BrwTestXSLT/text.xml
    http://ei4b.test.austin.ibm.com/BrwTestXSLT/text.html
 They are different.  They are in different fonts.
 The source code for the pages is the same.
 Changing the font preferences for the browser doesn't change their appearance.

 This is possibly a default font problem?

Expected Results:  
 They should look exactly the same.
 Toggle back and forth, no pixels should be different.

Reproducible: Always

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

14 years ago
Can't access testcase, hostname unknown.
I have the testcases accesible, but we should upload them to the XSLT QA site,
there's no reason for IBM to be the only ones that can do QA
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
Jonas, we shouldn't upload random tests to the QA site.
Put them on a public webserver, like sicking.cc and then we can find out if that
is indeed an XSLT problem and if we need regression tests. And if we are the
right component to provide them and maintain them.
This turns out to be caused by bug 190302. We choose default font depending on
which charset a page came from.
Status: NEW → ASSIGNED
Depends on: 190302
fixed with the checkin of bug 190302
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.