Unwanted attachment of auto-converted file: links when reediting Mail

RESOLVED DUPLICATE of bug 132257

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 132257
15 years ago
10 years ago

People

(Reporter: Christian Franke, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030925

When a HTML Mail with a link to a local file is reedited, file contents is
attached to the mail.


Reproducible: Always

Steps to Reproduce:
1. Compose a Mail in HTML Mode.
2. Enter a file://path URL (as plain text, not as a link). The path must refer
to an existing file.
3. Send the Mail to yourself as HTML (do not store it in Drafts folder).
4. Edit the received Message as New, do not edit anything.
5. Send the Mail to yourself as HTML.
Actual Results:  
Step 3: Mail contains auto-converted link: href="file://path",
class="moz-txt-link-freetext".
Step 5: Mail contains the file contents as an attachment and the link converted
accordingly: href="<cid:part1....>", class="moz-txt-link-freetext". Link text is
still unchanged: "file:\\path".


Expected Results:  
Both Mails should be identical.
Auto-converted links (class="moz-txt-link-freetext") should never be converted
to attachments.


The same effect occurs if the mail is simply stored to Drafts folder in Steps 3
and 5.
(Reporter)

Comment 1

15 years ago
This is possibly another interesting result of this bug:-)

Reproducible: Always

Steps to Reproduce:
1. Compose a Mail in HTML Mode.
2. Enter a file://path URL as a link (text and href identical). The File must exist.
3. Send the Mail to yourself as TEXT.

Actual Results:
Mail contains the URL followed by a link to an attachment, e.g.
"file:://path <cid:part1....>"
But the attachment "cid:part1..." does not exist.

Expected Results:  
Mail should only contain the URL (or attachment should exist).

Comment 2

15 years ago
Confirming.
Can reproduce this in a simple way:

1. Create HTML-Mail
2. "Insert - Link" via menu
3. type "text to display ..."
4. choose file
5. send mail, regardless of plain/html
6. recipient gets mail with attachment

File will not be attached when "text to display ..." is empty.

Comment 3

14 years ago
Confirming; I see this with
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040422
See bug 241573.

The symptoms in comment 1 are valid but are not really the same as the original 
report.  The results you and Peter Bauer report can also be seen by simply 
dragging a non-image file into the body of the HTML message.  See bug 241291 for 
a discussion of the various issues.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

14 years ago
(In reply to comment #1)
> Actual Results:
> Mail contains the URL followed by a link to an attachment, e.g.
> "file:://path <cid:part1....>"
> But the attachment "cid:part1..." does not exist.

That's bug 180997.

Sorry to be finding this so late, but this bug is a dupe; there is a bit of a 
patch there, but it's not clear that it's going anywhere.

*** This bug has been marked as a duplicate of 132257 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.