If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Find as you type loops infinitely on F3 or CTRL-G

VERIFIED DUPLICATE of bug 266338

Status

()

Toolkit
Find Toolbar
P4
normal
VERIFIED DUPLICATE of bug 266338
14 years ago
9 years ago

People

(Reporter: Oneweb, Assigned: Blake Ross)

Tracking

({access, helpwanted})

Trunk
x86
Windows 2000
access, helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925

FAYT loops infinitely instaed of stopping after first loop of page.

Reproducible: Always

Steps to Reproduce:
1. Go to any URL (for example, http://bugzilla.mozilla.org)
2. Enter some FAYT text (in this example  reproduce  )
3. Hit F3 or CTRL-G
4. Repeat step 3

Actual Results:  
FAYT loops infinitely over page.

Expected Results:  
FAYT should give a 'No more matches found' error if:
 The end of the page has been reached 
OR (even better)
 FAYT arrives back at the initial find match

Comment 1

14 years ago
In my opinion it's ok to work like this. Maybe the status bar should say that
you passed the end of file.

Comment 2

14 years ago
Good Lord, this is the way this feature is supposed to work.  That's what makes
it type-ahead find.
(Reporter)

Comment 3

14 years ago
Surely there should be /some/ sort of notification that the whole page has been
fayt'd? Any search/find function I've used in any program has at least a beep
when the search has done the whole page. I've found myself going through a page
several times without realising, and sometimes not knowing if I had covered a
whole page.

Comment 4

14 years ago
I always pay attention to the scroll bar for that or I remember what text I was
just looking at.  But I can see having some sort of notification as long as it
was totally unintrusive to the next find operation.  In other words, it
shouldn't show a message that needs to be cleared.  The other issue is you don't
want something ambiguous either.  It's really a tough thing to change, and I
wouldn't really advocate it myself.  People can do the old-fashioned search too.

Comment 5

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050122 Firefox/1.0+


Find has changed alot since this bug was filed, and now includes an indication
on the findbar which says "Reached end of page, contined from top."

Recommend closing this bug.

Comment 6

13 years ago
I recommend keeping it open. I never noticed that status bar message because my
eyes are where the search is, not on the status bar.

Here are a few options to make it noticable:
- audio cue
- flash the status bar message
- put a tooltip next to the found item

Not that I love any of those ideas, but just brainstorming.
Assignee: aaronleventhal → firefox

Updated

13 years ago
Component: Keyboard: Find as you Type → Find Toolbar / FastFind
Product: Core → Firefox

Comment 7

13 years ago
The current method of putting text on the status bar does not work well with a
screen reader. Audio cue would help.
Keywords: access

Updated

13 years ago
Keywords: helpwanted
Priority: -- → P4

Comment 8

13 years ago
(Re: Comment #7)

I have to admit that this morning I didn't notice the wrap-around notice on a
very large page (most of the hits were towards the middle, so it wasn't obvious
that the verticle scroll/slider had wrapped, which is how I usually notice the
wrap-around).

Perhaps a "soft" sound would help (not one that creates a "bing", but rather a
sound like the sound that is created when find switches to "phrase not found"
mode).  Hmmm... but that doesn't work either - I just tried it while listening
to music and I couldn't hear it.

Aaron probably has the best idea: flash or change the color of the toolbar.  Or
maybe the vertical scroll bar could change color or flash.   Just more
brainstorming.

Comment 9

13 years ago
I guess this bug could probably be marked as dup of Bug 266338, which explictly
asks for "Better (more visible) indication of when Find has wrapped or will wrap"

Comment 10

13 years ago
I concur that this bug should be marked as a duplicate of 266338.

Comment 11

13 years ago

*** This bug has been marked as a duplicate of 266338 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.