Mail filter rules are not 8-bit clean.

RESOLVED DUPLICATE of bug 152888

Status

RESOLVED DUPLICATE of bug 152888
15 years ago
11 years ago

People

(Reporter: achowe, Assigned: sspitzer)

Tracking

({intl})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

1.5 RC2

Trying to apply filtering rules with characters like the english Pound Sterling
sign or the Euro won't work. Like wise if you copy-paste foreign undisplayable
characters from korean, chinese, etc. spam mail and paste it into a rule and
then try to Run Now the rule.

Reproducible: Always

Steps to Reproduce:
1. Create a new mail filter rule.
2. Add the english pound or euro currency symbols to Subject contains line.
3. Save the rule
4. Select it and click Run Now.

Actual Results:  
Fails to operate with a dialog message.

Expected Results:  
That messages with those symbols (or byte combinations) are filters.

Comment 1

15 years ago
This looks rather like bug 152888.  Not sure if it should be counted as a dupe
though.
(Reporter)

Comment 2

15 years ago
Apon reading 152888, it sounds very much like my own case. To add to 152888
comment #4, I copy/pasted the characters (bytes) as seen from my english viewing
persepective. As for the english pound and euro symbol, I can type them from the
keyboard, yet the filter fails when I run it.

Comment 3

15 years ago
If every email message (even spam mails) is compliant to RfC 2047, it'd be
relatively easy to fix this, but most spam mails use 'raw' octets with MSB set
(violating RFC 2047) in the mail header(Subject, From, etc), which makes it more
difficult than otherwise to fix this and bug 152888
Keywords: intl

Comment 4

15 years ago
I should have marked this as dupe of bug 152888. Reading it convinced me that
it's a dupe. 

*** This bug has been marked as a duplicate of 152888 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.