[CSS] Table can't be positioned absolute to the right and bottom of document

RESOLVED DUPLICATE of bug 145572

Status

()

--
major
RESOLVED DUPLICATE of bug 145572
15 years ago
14 years ago

People

(Reporter: g.teunis, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925 Firebird/0.7

When positioning a table with CSS
i.e.
<table style="position: absolute; right:50;bottom:50;">
Doesn't paint the table to the lower right corner, a
<table style="position: absolute; left:50;top:50;">
positiones well! It is drawn at 50,50 in the document..
So the right and bottom doesn't work (left and top does).

Document load correctly on IE and Opera

Reproducible: Always

Steps to Reproduce:
1. http://wenus.cjb.net/table_positioning.htm
2. 
3.

Actual Results:  
Incorrect positioning of tables (all in left top corner)

Expected Results:  
One table aligned at the left side, one on right side, one on top and one at bottom.

There are a lot of pages positioning tables to the right or bottom of a page, so
it's a above normal bug?
(Reporter)

Comment 1

15 years ago
Created attachment 132455 [details]
Testcase

Test case (try in IE and Mozilla/Firebird to see difference!)
(Reporter)

Comment 2

15 years ago
Created attachment 132456 [details]
Screenshot of IE correcly rendering
(Reporter)

Comment 3

15 years ago
Created attachment 132457 [details]
Screenshot of Firebird incorrecly rendering
This is basically bug 53663, but just marking dependent for now.
Depends on: 53663
(Reporter)

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 53663 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

15 years ago
The "position:absolute; right:100px;" boxes aren't showing correctly 
(not 100 pixels from the right border).

Tested it with 50, wich results in partly in document and partly out document
display (outside results in wider document with scrollbar).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

15 years ago
This seems to be fixed not that bug 53663 is fixed, can anyone verify?

*** This bug has been marked as a duplicate of 53663 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

15 years ago
Not fixed I fear,
The box wich is right aligned is too far to the right,
Please check my testcase and then look at the IE screenshot (witch renders
correctly).

Hope this will be fixed soon :)
(Reporter)

Comment 10

15 years ago
Comment on attachment 132455 [details]
Testcase

<html>

<!-- LEFT ALIGNED -->
<table border=1 width=50 STYLE="position:absolute; left:100px;">
	<tr>
		<td>
			Left Aligned Table (left:100px)
		</td>
	</tr>
</table>


<!-- RIGHT ALIGNED -->
<table border=1 width=50 STYLE="position:absolute; right:0px;">
	<tr>
		<td>
			Right Aligned Table (right:0px)
		</td>
	</tr>
</table>

<!-- TOP ALIGNED -->
<table border=1 width=50 STYLE="position:absolute; top:100px;">
	<tr>
		<td>
			TOP Aligned Table (top:100px)
		</td>
	</tr>
</table>

<!-- BOTTOM ALIGNED -->
<table border=1 width=50 STYLE="position:absolute; bottom:0px;">
	<tr>
		<td>
			BOTTOM Aligned Table (bottom:0px)
		</td>
	</tr>
</table>

</html>
(Reporter)

Comment 11

15 years ago
Created attachment 136343 [details]
Firebird renders right aligns too far to the right
(Reporter)

Comment 12

15 years ago
Perhaps I should make a new report for this.
Sorry for the high update rate of this bug.

STYLE="position:absolute; right:0px;" renders the box outside the screen, please
look at new screenshot (witch is positioned at right at 0px)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 13

15 years ago
you could mark as a dupe of bug 145572 :-)
(Reporter)

Comment 14

15 years ago

*** This bug has been marked as a duplicate of 145572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.