Build fails with new MinGW GCC 3.3.1 candidate on WinXP

RESOLVED FIXED in mozilla1.6alpha

Status

()

Core
XPCOM
P2
normal
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Nilson Cain, Assigned: dbaron)

Tracking

Trunk
mozilla1.6alpha
x86
All
Points:
---
Bug Flags:
blocking1.6a -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030930 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030930 Firebird/0.7+

Build fails with new MingW GCC 3.3.1 candidate. Just made a successful build
last night with GCC 3.2.3.  The only thing shanged is upgraded GCC.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 132495 [details]
config.log
(Reporter)

Comment 2

15 years ago
Created attachment 132496 [details]
Last 105 lines of console output
(Reporter)

Comment 3

15 years ago
Created attachment 132497 [details]
/mozilla/.mozconfig
(Reporter)

Updated

15 years ago
Attachment #132497 - Attachment mime type: application/octet-stream → text/plain

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 220291 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

15 years ago
I'd rather have this as dependent than duplicate.
Status: RESOLVED → UNCONFIRMED
Depends on: 220291
Resolution: DUPLICATE → ---
(Assignee)

Comment 6

15 years ago
taking
Assignee: mozbugs-build → dbaron
Status: UNCONFIRMED → NEW
Component: Build Config → XPCOM
Ever confirmed: true
Priority: -- → P2

Comment 8

15 years ago
Not Windows XP only --> OS: All.
OS: Windows XP → All

Comment 9

15 years ago
Ditto with Nilson's report.  Also, several on the mozillazine forums seem to
have had 3.3.1 build problems fixed by that patch.

Comment 10

15 years ago
The patch from 220291 fixed the problem on my gcc 3.3.1 from cygwin
Flags: blocking1.6a?

Comment 11

15 years ago
I don't think we'd block the release for this bug but we'd consider approving a
fully reviewed patch. 
Flags: blocking1.6a? → blocking1.6a-
Shouldn't this bug be now closed as it has been reported that the patch for
220291 (which has beenchecked in) resolves the issue?
(Assignee)

Comment 13

15 years ago
Yep.
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.6alpha
You need to log in before you can comment on or make changes to this bug.