If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IFRAMES: Background color of parent is used in IFRAME instead of browser default.

RESOLVED DUPLICATE of bug 154957

Status

()

Core
Layout: HTML Frames
--
minor
RESOLVED DUPLICATE of bug 154957
14 years ago
14 years ago

People

(Reporter: Raffaele Ruffaldi, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

522 bytes, application/x-zip-compressed
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

if the source of a inline-frame has no background color specified, it will be
displayed with the same background as the document containing the Iframe.

Reproducible: Always

Steps to Reproduce:
1. Create a html file with a bg color different than your browser default
containing an Iframe
2. Create the html file to be contained. DO NOT specify any backgtround color
info in this page

Actual Results:  
the page in the IFrame is displayed with the same bg color as the page
containing the IFrame

Expected Results:  
It should have displayed the html in the Iframe with the default bg color
(Reporter)

Comment 1

14 years ago
The problem can be solved my specifong the bg color of every HTML file in a
IFrame. BUT, this may cause problem with auto generated HTML like the default
error pages of Apache. (see the url provided for some 404 an exemple)
(Reporter)

Comment 2

14 years ago
Created attachment 132617 [details]
Exemple case HTML
Bug 154957 explains why we do it this way.

*** This bug has been marked as a duplicate of 154957 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.