composer crashed after typing a few characters [@ nsDocument::GetRootContent][@ __pure_virtual - nsAString::do_AssignFromReadable]

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
--
critical
RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: Robert T. Drury, Unassigned)

Tracking

({crash})

Trunk
All
Linux
crash
Bug Flags:
blocking1.7b -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Debian? DUPEME?, crash signature)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6a) Gecko/20031004
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6a) Gecko/20031004

Crashes after typing a few characters in composer.  Also crashes if you switch
to source edit mode and back.  Consistent.

 

Reproducible: Always

Steps to Reproduce:
1. run mozilla
2. new composer window
3. type three or four characters into composer window



Actual Results:  
crash

Comment 1

14 years ago
Robert: Could you provide stacktrace or TalkBack incident ID?
Keywords: crash
(Reporter)

Comment 2

14 years ago
Created attachment 132750 [details]
gdb backtraces - composer crash

Comment 3

14 years ago
same thing with Mozilla 1.5
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.5) Gecko/20031111

Comment 4

14 years ago
same thing with Mozilla 1.5
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.5) Gecko/20031111

Comment 5

14 years ago
Confirming for 1.6 i686 Linux. You even need not to type anything, just exit 
after open, and it crashes 3 seconds later (short CPU bump observed). Just 
touching one of the cursor keys has the same effect. Composer seems to be 
completely unusable now => regression.
 
I tested all my Mozillas here

   release 1.5 official, linux, WFM
   nightly 200401014, linux, WFM
   nightly 20040114, winxp, WFM

Will test with a more recent linux build in a few minutes.
tested 20040124 nightly on Lindows0S 4.5 (debian) : WFM

I nobody confirms the bug with a recent build (I insist : 20040124 *is*
recent), 1.5 is not), I'll close the bug as WFM...
Assignee: composer → daniel

Comment 8

14 years ago
Hmm, sounds like some issue with an external library. I'm using a gccc2.95.3
compiled build 1.6 final with glibc-2.2.1, gtk/glib 1.2.9.
(Reporter)

Comment 9

14 years ago
I'm using similar versions of those packages.    

Comment 10

14 years ago
I see the same bug with a when using a debian backport. 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040122
Debian/1.6-0.backports.org.1

Also, we are experiencing the same whenever we use an html editor availible from
classfronter (http://www.fronter.com)

using the same machine, but using a binary from mozilla.org does not have this
problem: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031210

(okay, it's an old one, but nevertheless)

Comment 11

14 years ago
it also happens on the mozilla-firebird backport:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031215 Firebird/0.7

This is when using the html-editor on http://www.fronter.com

Comment 12

14 years ago
Using the Mozilla compile available from backports.org 
(http://www.backports.org/debian/pool/main/m/mozilla/) running on the 
Skolelinux distribution (http://www.skolelinux.no/) I can reproduce this 
constantly at http://www.mozilla.org/editor/midasdemo/ - output is: "Pure 
virtual method called" and an untimely Mozilla death. 

Comment 13

14 years ago
I can confirm the crash in comment #12. Seems that a major component is dead for
a lot of people. Asking for blocking 1.7b since backports should be possible at
least to the last before recent linux release.
Flags: blocking1.7b?

Comment 14

14 years ago
The Mozilla compile available from backports.org 
chrashes after typing a few characters in Composer.

Comment 15

14 years ago
Not going to hold the release for something that doesn't happen in mozilla.org
binaries.
Flags: blocking1.7b? → blocking1.7b-

Comment 16

14 years ago
I've tested a bit, and though this might be of most interest for Debian Woody
users, I've list what I've found. 

The backports from http://www.backports.org/debian/ does not work
The binary from http://www.mozilla.org works
The packaged version for Debian Sarge (testing) does work. 
The difference is that the backport is compiled with gcc 2.95.4, the other with
some recent gcc 3.x 

The binary from mozilla.org, and the one Debian sarge needs java 1.4, with
libraries from gcc3.2 or later. 

I took the package from Sarge, and recompiled it on a Woody-installation, using
default setup. This lead to a mozilla, that crashed with composer, and the midasdemo
Then I rebuilt with gcc 3.0 which also is availible for Woody.
now the composer works, and also the midasdemo. 

I think the requrements on gcc should be bumped to at least 3.0, and then this
bug can be closed as WorksForMe or WontFix, or something other appropriate

For thos that want a working solution on Debian Woody, add to their source list: 
 deb http://ftp.skolelinux.no/ ~finnarne/mozilla/
 deb-src http://ftp.skolelinux.no/ ~finnarne/mozilla/

After some time(give it some days), The files will appear in 
 deb http://ftp.skolelinux.no/skolelinux woody local
 deb-src http://ftp.skolelinux.no/skolelinux woody local

Comment 17

14 years ago
>> I think the requrements on gcc should be bumped to at least 3.0, and then this
>> bug can be closed as WorksForMe or WontFix, or something other appropriate
I'm always reluctant to require a specific compiler version for any package.
Either it's legal C++, or it's not; or a specific defect of a compiler is known.
If so, the first step should be to find a way to circumvent the bug (be friendly
to unable compilers...). Only if the effort for a workaround is unacceptable or
would block a major enhancement, a specific requirement is justified.
But if you just don't know why the new compiler works and the old one not, the
very first step is to FIND OUT WHY. Typically, such an unexplainable behaviour
is just a hidden bug. From my long time experience, it's really worth the 
effort to always trace the problem down to its source. Problems should always 
be eradicated instead of hidden by accident.

Updated

14 years ago
Hardware: Other → All
Product: Browser → Seamonkey

Comment 18

13 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 19

13 years ago
in some cases gcc tends to suck, the pure virtual may be a hint about one of
those cases.

The GetRootContent item seems like a more mozilla-ish issue to me.
Summary: composer crashed after typing a few characters → composer crashed after typing a few characters [@ nsDocument::GetRootContent][@ __pure_virtual - nsAString::do_AssignFromReadable]
Whiteboard: Debian? DUPEME?

Comment 20

13 years ago
Here is what I get from 1.8a6 compiled as in comment #8 (crashes as well):

An error occurred updating the cmd_align command: 
[Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POI
NTER) [nsICommandController.getCommandStateWithParams]"  nsresult: "0x80004003 (
NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://editor/content/Compo
serCommands.js :: goUpdateCommandState :: line 258"  data: no]
An error occurred updating the cmd_absPos command: 
[Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POI
NTER) [nsICommandController.getCommandStateWithParams]"  nsresult: "0x80004003 (
NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://editor/content/Compo
serCommands.js :: goUpdateCommandState :: line 258"  data: no]
/opt/mozilla/run-mozilla.sh: line 72:   370 Segmentation fault      "$prog" ${1+
"$@"}
Assignee: daniel → nobody
QA Contact: chrispetersen → composer

Comment 21

9 years ago
This seems to be long gone.
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) 
    Gecko/20080715 SUSE/1.1.11-1.1 SeaMonkey/1.1.11

Comment 22

7 years ago
(it's not the reporter but)
WFM per comment 21
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsDocument::GetRootContent] [@ __pure_virtual - nsAString::do_AssignFromReadable]
You need to log in before you can comment on or make changes to this bug.