If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Download cannot save to default directory. When chosing another directory to save to, download is fine.

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Pat Chee, Assigned: Blake Ross)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20030930
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20030930

Mac OSX 10.1.5 Build: 2003093005

I don't know if its just a problem on my computer but I am having trouble
downloading to my desktop completely.  It will download what looks like most of
the file and a dialog pops up and says something to the effect of
"/Users/mydirectory/Desktop/nameoffile.gz could not be saved, because an unknown
error occurred.  Sorry about that. Try saving to a different location."  

I then retry the download to another location and the download works just fine. 

The good thing is that the browser's not crashing on downloads (which earlier
builds did).  The bad thing is it isn't downloading to  the default download place.

Again, this is an improvement over not being able dow download at all but is an
otherwise rather inconvenient bug

Reproducible: Always

Steps to Reproduce:
1.Click on a link to download a file (.sit .gz .hqx etc.)
2.Download proceeds as expected up until it is nearly finished

Actual Results:  
Error dialog pops up on top of saving dialog informing me that the file could
not be saved in the location (my desktop) because of an unknown error.  This
happens even though there is plenty of drive space available and the download is
nearly complete.

Expected Results:  
It should have saved the file to the desktop (my default location)

No crash to report.  Browser still functions and downloads completely if told to
save to an alternate location.

Comment 1

14 years ago
not an OS-X user, but maybe is something related to bug 213639; supposedly, all
downloading problems should be gone starting with the build from 09-30; but
you're using exactly this build ...
Download _crashes_ should be gone.  There are also existing bugs with downloads
not completing like this on Mac OSX, though....
Whiteboard: DUPEME
(Reporter)

Comment 3

14 years ago
Yes bug 213639 might be related, but this problem is different because downloads
never got this far with earlier OSX builds.  As mentioned by Boris, bug 213639
and its resolution addressed the browser crashing. (I should know I was an
active tester.)  This bug does not crash the browser but makes downloading
inconvenient.  I'll try changing the default download area and see if this makes
a difference.  If it is any indication, Camino downloads the exact same
attempted file just fine to the desktop so I'm guessing it is likely not a file
directory problem with the OS.

Incidentally I tried to post a comment about this bug to bug 213639 but bugzilla
kept giving me an error disallowing me to do so.
(Reporter)

Comment 4

14 years ago
Now using build 2003100505

Ok unlike other browsers I've encountered one cannot change the default download
folder from within Mozilla.  I decided the second best would be to use the
internet control panel.  We'll see if that makes any difference.  More news when
it happens

Comment 5

14 years ago
Hmm... this looks like a dupe of bug 166369.
Depends on: 166369
(Reporter)

Comment 6

14 years ago
hmmm it does look related.  Almost exact same symptoms and everything but 166369
is based on Mozilla 1.2.1 .... and I don't remember having this problem with
that version of Mozilla.
(Reporter)

Comment 7

14 years ago
Attempting to change default download directory through Mac OSX Internet control
panel appears to do nothing for Mozilla.  Downloading error persists.

Comment 8

14 years ago
Pat, can you reproduce this with a current build?
(Reporter)

Comment 9

14 years ago
Hey~ the most recent build I downloaded (20031225) seems to have fixed this bug.
 The file downloads and doesn't give an error message.  I'll have to do a couple
more tries to be sure but so far so good.

Comment 10

14 years ago
OK. Resolving as wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Whiteboard: DUPEME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.