Closed Bug 221463 Opened 16 years ago Closed 16 years ago

Changing attribute doesn't redraw pseudoelement before/after correctly

Categories

(Core :: Web Painting, defect, minor)

x86
Windows 98
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 214013

People

(Reporter: daniel, Assigned: roc)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

Changing attributes of an element using setAttribute() doesn't force a redraw,
when the element's content get's generated by CSS using the before/after pseudo
element:

.mw:before {
  content:"[mw:" attr(valueMen) "/" attr(valueWomen) "]";
}
	
Now when changing any attribute the element's content doesn't update correctly.
It usually just doesn't display anything or shows the old value. Actually the
size of the element doesn't update to the new size of the content. When hiding
the element and showing it again, it will be drawn correctly.

Reproducible: Always

Steps to Reproduce:
See example page


Expected Results:  
The pseudoelement's content should be updated as soon as an used attribute changes

*** This bug has been marked as a duplicate of 214013 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.