Closed Bug 221475 Opened 16 years ago Closed 16 years ago

Mozilla hangs during startup

Categories

(SeaMonkey :: General, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 221217

People

(Reporter: mozilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: CVS checkout from 7 October

If I start Mozilla from command line I get a stack listing (... stands for complete path 
to mozilla): 
 
<---- ... stuff removed ... ----> 
 
nNCL: registering deferred (0) 
/home/jarmo/.netscape exists:  0 
no 4.x profile 
*** Chrome Registration of package: Checking for contents.rdf at 
jar:resource:/chrome/comm.jar!/content/necko/ 
 
Program .../dist/bin/mozilla-bin (pid = 10699) received signal 11. 
Stack: 
UNKNOWN [/lib/libpthread.so.0 +0x0000B895] 
UNKNOWN [/lib/libc.so.6 +0x000295C8] 
nsOSHelperAppService::nsOSHelperAppService()+0x0000006F 
[.../dist/bin/components/libdocshell.so +0x000B08FF] 
UNKNOWN [.../dist/bin/components/libdocshell.so +0x00054EC6] 
 
<---- ... stuff removed ... ----> 
 
main+0x00000182 [.../dist/bin/mozilla-bin +0x000206F2] 
__libc_start_main+0x000000CE [/lib/libc.so.6 +0x000158AE] 
Sleeping for 5 minutes. 
Type 'gdb .../dist/bin/mozilla-bin 10699' to attach your debugger to this thread. 
 
<---- ... end if console listning ... ----> 
 
If I do what is suggested (attach gdb) I can get a back trace (sometimes): 
 
<---- ... gdb back trace ... ----> 
 
(gdb) bt 
#0  0x406d7166 in nanosleep () from /lib/libc.so.6 
#1  0xffffff90 in ?? () 
BFD: BFD 2.13.90 20020903 assertion fail libbfd.c:1132 
 
<---- ... the same line repeated a huge count ... ----> 
 
BFD: BFD 2.13.90 20020903 assertion fail libbfd.c:1132 
#2  0x08071c16 in ah_crap_handler(int) (signum=11) at nsSigHandlers.cpp:135 
#3  0x40107895 in __pthread_sighandler () from /lib/libpthread.so.0 
#4  <signal handler called> 
(gdb) 

Reproducible: Always

Steps to Reproduce:
1. Start mozilla 
2. 
3. 
Actual Results:  
Nothing, not even a crash.
Did you build with gtk2?  Do you have the GNOME libraries installed?
gtk2 : yes. 
Gnome : partly (Basically KDE) 
 
Has dependencies changed? 
As Mozilla has built on this computer before and Ive done no changes (beyond 
automated SuSE updates). 
 
My configure switches are: 
 
./configure --disable-pedantic --disable-ldap \ 
            --disable-logging --disable-tests \ 
            --enable-crypto --enable-optimize=-O2 \ 
            --enable-default-toolkit=gtk2 
 
Still no luck with Mozilla (CVS from 10/10). Checked the file in question 
("/usr/lib/libgtk-x11-2.0.so.0.200.1" as noted in bug 221217). The file _is_ there. No 
need to create a dummy symlink. But still Mozilla crashes as before. 
 
Either I missunderstand "the fix" or this aint the same bug. 
 
Bug 221217 also talks about "/usr/lib/libgnome.so", dir /usr/lib/libgno*" gives nada on 
my system. 
Yeah, if you built with gtk2 and have no libgnome....

*** This bug has been marked as a duplicate of 221217 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.