Quicksearch enhancements and allow to use quicksearch in the Bug# box of the footer

RESOLVED DUPLICATE of bug 70907

Status

()

Bugzilla
User Interface
--
enhancement
RESOLVED DUPLICATE of bug 70907
14 years ago
12 years ago

People

(Reporter: Ludovic Dubost, Assigned: myk)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

This parch enhances quicksearch and the search boxes:

- Allow a ALL or OPEN bugs search
- allow to add keywords to the search fields (this means removing the blocking
of searches on keywords that are unknown)
- Enable quicksearch in the Bug# field

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Created attachment 132805 [details] [diff] [review]
Patch against 2.17 Head

Enhancements to the quicksearch functionality and search boxes
(Reporter)

Updated

14 years ago
Attachment #132805 - Flags: review?

Comment 2

14 years ago
Some unofficial suggestions from a patch tester:

--> your patch contains the web.ref and the web.dev directories; a patch without
those would be much more helpful; to produce it, use "cvs diff -uN ." for
example in your web.dev directory instead of doing "diff -uN web.ref web.dev" or
something similar.
--> try to have an unique identation:

+ 			add_chart("short_desc","substring",w);
+                        add_chart("status_whiteboard","substring",w);

This will also remove changes like this one:

-                            }
+                           }

--> try to use the 4-space identation rule:

+function removeALL(value)
+{
+ var i = 0;
+ var str = value;
+ while (true || (i==4) ) {
+  i++;
+  if (str.indexOf("ALL ")!=0)
+   break;
+  str = str.replace("ALL " , "");
+ }
+ return str;
+}

Those are only (unofficial) suggestions after a first look. Thanks for
implementing these!

Comment 3

14 years ago
Oh, and inside templates, 2-space identation is used, so inserting the line
below requires to push all other lines to right with 2 spaces:

     [% ELSE %]
+     [% IF noactions != 1 %]
       <td valign="middle" align="right">

Updated

14 years ago
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 4

14 years ago
Thanks for the suggestions.. I'm not sure about the web.dev/web.ref thing..
The way I handle it is using patch -p1 -i to apply them without any problems..
But if the 'official' way for bugzilla patches is to have them without this
level of directory I can change that..

Concerning the identation in the following example

    [% ELSE %]
+     [% IF noactions != 1 %]
       <td valign="middle" align="right">

If I do add the 2 spaces in all the code then the diff will show much more lines
modified.. I understand the end result is not so nice.. but wouldn't it be a
trading good for bad ? 

What's the prefered way of bugzilla hackers ?

Ludovic

Comment 5

14 years ago
In http://bugzilla.org/developerguide.html it's said "HTML Templates should have
a 2-space indent.", and in http://bugzilla.org/reviewerguide.html , in the
Template Review Checklist section, "# check template style *  2 space indenting"
is specified.

(So it's highly unlikely to get a r+ on a patch that doesn't follow the indent
rule, even if it's done for "nobel" purposes :-) )
(Reporter)

Comment 6

14 years ago
Ok.. who's doing a program that automatically reindents the code based on the
right conventions :)

I'll submit a new patch when I have time..

Comment 7

14 years ago
Apparently GNU does one - http://www.gnu.org/software/indent/indent.html :)

Comment 8

14 years ago
Comment on attachment 132805 [details] [diff] [review]
Patch against 2.17 Head

Bitrotten, and there are also numerous indentation issues (with only one space
being used for indentation).
Attachment #132805 - Flags: review? → review-
This is at least blocked by bug 70907. Maybe it's even a duplicate of it, or
being fixed by it.
Depends on: 70907

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 10

12 years ago
Suggest DUPLICATE of bug 70907.

ALL or OPEN bugs are apparently being covered already.  Keywords are apparently
also searched.  The search box in index.html is also being modified.  All of
these are mentioned in attachment 192270 [details] [diff] [review] of bug 70907.

Comment 11

12 years ago
Yeah, with how many different issues there are in the original report, it's a
duplicate. For just the "bug # box" thing I would have marked it as [blocker
will fix].

*** This bug has been marked as a duplicate of 70907 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
No longer depends on: 70907
Resolution: --- → DUPLICATE
Whiteboard: [blocker will fix]
Version: unspecified → 2.17
Whiteboard: [blocker will fix]
You need to log in before you can comment on or make changes to this bug.