crash on opening some (but not all) hebrew pages

RESOLVED DUPLICATE of bug 200511

Status

()

--
critical
RESOLVED DUPLICATE of bug 200511
15 years ago
10 years ago

People

(Reporter: ghoffman, Assigned: mkaply)

Tracking

({stackwanted})

Trunk
PowerPC
Mac OS X
stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB24200682K, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031007
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031007

This might be related to 176877, but since it's on a different platform, I
decided to open a new one. 

Opening some hebrew pages crashes after short attempt to load the page - no
content is shown. Examples: http://www.haaretz.co.il  http://www.maariv.co.il -
other hebrew pages show, but become increasingly slow up to a point of no
reaction - for example http://www.news-israel.net

This is not a new bug and I have experienced this since 1.5rc1 at least
(possibly dating back to 1.4.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.haaretz.co.il
2. Crash
3. Open http://www.news-israel.net
4. Experience increasingly long waiting times
(Reporter)

Comment 1

15 years ago
See: Talkback incident: TB24200682K
caillon, can you still get stacks?  If not, who can?
Keywords: stackwanted
Whiteboard: TB24200682K
Stack from TB24200682K:
GetQDGlobalsBlack()
0x0917fd70
0x091ec964
0x0917e8d4
0x091fdbbc
0x091dc848
0x091e313c
0x091ec62c
0x0920faec
0x09175070
0x091749b0
ns4xPluginStreamListener::OnDataAvailable()
[/builds/nightly/seamonkey/trunk/mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp,
line 422]
nsPluginStreamListenerPeer::OnDataAvailable()
[/builds/nightly/seamonkey/trunk/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp,
line 2237]
nsStreamListenerTee::OnDataAvailable()
[/builds/nightly/seamonkey/trunk/mozilla/netwerk/base/src/../../../dist/include/xpcom/nsCOMPtr.h,
line 667]
nsHttpChannel::OnDataAvailable()
[/builds/nightly/seamonkey/trunk/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp,
line 3421]
nsInputStreamPump::OnStateTransfer()
[/builds/nightly/seamonkey/trunk/mozilla/netwerk/base/src/nsInputStreamPump.cpp,
line 421]
nsInputStreamPump::OnInputStreamReady()
[/builds/nightly/seamonkey/trunk/mozilla/netwerk/base/src/nsInputStreamPump.cpp,
line 322]
nsInputStreamReadyEvent::EventHandler()
[/builds/nightly/seamonkey/trunk/mozilla/xpcom/build/../../dist/include/xpcom/nsCOMPtr.h,
line 574]
PL_HandleEvent()
[/builds/nightly/seamonkey/trunk/mozilla/xpcom/threads/plevent.c, line 672]
PL_ProcessPendingEvents()
[/builds/nightly/seamonkey/trunk/mozilla/xpcom/threads/plevent.c, line 606]
_md_EventReceiverProc()
[/builds/nightly/seamonkey/trunk/mozilla/xpcom/threads/plevent.c, line 1566]
DispatchEventToHandlers()
SendEventToEventTargetInternal()
SendEventToEventTargetWithOptions()
ToolboxEventDispatcherHandler()
DispatchEventToHandlers()
SendEventToEventTargetInternal()
SendEventToEventTarget()
ToolboxEventDispatcher()
CallEventDispatchHook()
TryEventDispatcher()
GetOrPeekEvent()
GetNextEventMatchingMask()
WNEInternal()
WaitNextEvent()
nsMacMessagePump::GetEvent()
[/builds/nightly/seamonkey/trunk/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 407]
nsMacMessagePump::DoMessagePump()
[/builds/nightly/seamonkey/trunk/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 312]
nsAppShell::Run()
[/builds/nightly/seamonkey/trunk/mozilla/widget/src/mac/nsAppShell.cpp, line 114]
main1()
[/builds/nightly/seamonkey/trunk/mozilla/xpfe/bootstrap/../../dist/include/xpcom/nsCOMPtr.h,
line 673]
main() [/builds/nightly/seamonkey/trunk/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1682]
_start() [/SourceCache/Csu/Csu-45//SourceCache/Csu/Csu-45/crt.c, line 267]
start() 

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 200511 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.