loading tabbed bookmarks loads over existing tabbed browser windows

RESOLVED DUPLICATE of bug 208278

Status

SeaMonkey
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 208278
15 years ago
13 years ago

People

(Reporter: Philip Pierce, Assigned: Pierre Chanial)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

In Mozilla 1.4 and prior, when loading a tabbed bookmark (a bookmark with more
than one entry in it), the new tabbed windows would open in the same browser,
but in different additional tabs to the ones already existing in the browser.
This way, I could load two tabbed bookmarks and have both on the same browser at
the same time.

Mozilla 1.5 RC2 breaks this. When loading a tabbed bookmark, it loads into the
existing tabs in the browser. This is undesirable because I want to keep my
existing tabs while also loading new tabs from the bookmarks.

Reproducible: Always

Steps to Reproduce:
1. Open two tabs in the existing browser
2. Load a bookmark with two or more items (tabbed bookmarks)
3. The bookmark will load into the existing tabs in the browser. It should
create the tabs needed for the bookmark and load into that (as Mozilla 1.4 and
prior do).

Actual Results:  
The bookmarks loaded into my existing tabs instead of creating their own tabs.

Expected Results:  
Mozilla should have created its own tabs to load the bookmarks into, as Mozilla
1.4 and prior do.

Comment 1

15 years ago
There is now a pref to get the old behaviour back:
Edit->Preferences->Navigator->Tabbed Browsing
When opening a bookmark group
(x) Add tabs               (this has been the old behaviour)
( ) Replace existing tabs  (this is the new default)

*** This bug has been marked as a duplicate of 208278 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.