HTML documents and CGI scripts should reside in different directories

RESOLVED DUPLICATE of bug 44659

Status

()

Bugzilla
Installation & Upgrading
--
enhancement
RESOLVED DUPLICATE of bug 44659
15 years ago
6 years ago

People

(Reporter: Ulrich Windl, Assigned: zach)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20021204
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20021204

I'm having trouble configuring Apache2 to execute CGI scripts, but not HTML
files in the bugzilla directory. Either Apache will execute both, or display
both. It would be much easier if both types of files would live in different
directories.
Alternatively, improve the documentation.

Reproducible: Always

Steps to Reproduce:




Expected Results:  
HTML displayed, CGI executed.
(Reporter)

Updated

15 years ago
Version: unspecified → 2.16.3
you need
 AddHandler cgi-script .cgi
 Options +ExecCGI
on the <Directory> block for your Bugzilla directory (and the <Directory> block
needs to specify the real path, not a symlink).

Beyond that, the suggestion of separating the HTML from the cgi is I believe the
intention of bug 44659, so making this a dupe of that one.

*** This bug has been marked as a duplicate of 44659 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.