Crash loading ESPN story pages [@ nsWindow::NativeCreate]

RESOLVED DUPLICATE of bug 205492

Status

--
critical
RESOLVED DUPLICATE of bug 205492
15 years ago
10 years ago

People

(Reporter: zwalters, Assigned: blizzard)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Trying to load a story page on ESPN crashes firebird ~3-4 seconds after click. 
Story text will display; page looks relatively normal while download continues,
but the browser crashes at about the time you'd expect the page download to be
completed.

Reproducible: Always

Steps to Reproduce:
1.go to espn.com.  The main index page displays well, and you can wait some time
after loading to ensure that the browser won't crash.  This works for other
index pages, too -- if you click on MLB, the baseball index page displays correctly.
2.Click on a story.  Wait a few seconds.  The story text will often display
correctly, and the page will look fine.  Then firebird crashes.
3.

Actual Results:  
firebird crashes.  No error message.


firebird 0.7 for i686, gtk2+, xft-enabled.  I switched from 0.6.1 yesterday, so
this may be the first time I've used this build to access espn.com.  The only
extension I have is RadialContext.

Comment 1

15 years ago
The following URL causes mozilla to crash on my box.  I'm using the Xft/redhat-8
RPMs provided on the mozilla.org website.

Searching buzilla for 'espn crash', it looks like there are additional reports:
221806 205282

Linux localhost.localdomain 2.4.22 #4 Wed Oct 8 15:54:49 EDT 2003 i686 i686 i386
GNU/Linux

Mozilla 1.4, Copyright (c) 2003 mozilla.org, build 2003090317


http://sports.espn.go.com/mlb/playoffs2003/news/story?id=1634711

Comment 2

15 years ago
*** Bug 221806 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
Confirming new based on dup'ed bug.  Moving to Browser since Mozilla crash
observed in comment 1.

WFM 20031001 PC/Win2K.  Possibly/probably a Linux-specific issue.
Assignee: blake → general
Status: UNCONFIRMED → NEW
Component: General → Browser-General
Ever confirmed: true
Keywords: crash
Product: Firebird → Browser
QA Contact: general
Summary: Loading espn story page crashes firebird 0.7 RC → Crash loading ESPN story pages
Version: unspecified → Trunk

Updated

15 years ago
Blocks: 198955

Comment 4

15 years ago
Created attachment 133133 [details]
stacktrace

(gdb) frame 4
#4  0x41aa1066 in nsWindow::NativeCreate(nsIWidget*, void*, nsRect const&,
nsEventStatus (*)(nsGUIEvent*), nsIDeviceContext*, nsIAppShell*, nsIToolkit*,
nsWidgetInitData*) (this=0x89740e0, aParent=0x0, aNativeParent=0xbfffd130,
aRect=@0xbfffcb64, 
    aHandleEventFunction=0x88353e8, aContext=0x0, aAppShell=0x0,
aToolkit=0xbfffd110, aInitData=0x41ab57e7) at nsWindow.cpp:2156
2156	    g_object_set_data(G_OBJECT(mDrawingarea->clip_window), "nsWindow",
(gdb) p mDrawingarea
$1 = (MozDrawingarea *) 0x0

Comment 5

15 years ago
==> gtk
Assignee: general → blizzard
No longer blocks: 198955
Component: Browser-General → GFX: Gtk
QA Contact: general → ian
Summary: Crash loading ESPN story pages → Crash loading ESPN story pages [@ nsWindow::NativeCreate]

Comment 6

15 years ago
dupe of a bug with the same stacktrace

*** This bug has been marked as a duplicate of 205492 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
Crash Signature: [@ nsWindow::NativeCreate]
You need to log in before you can comment on or make changes to this bug.