Last Comment Bug 221842 - password manager stores more than username and password
: password manager stores more than username and password
Status: VERIFIED DUPLICATE of bug 153986
:
Product: Toolkit
Classification: Components
Component: Password Manager (show other bugs)
: unspecified
: x86 Windows XP
: -- minor (vote)
: ---
Assigned To: Brian Ryner (not reading)
: David P James
: Matthew N. [:MattN] (PM me if requests are blocking you)
Mentors:
http://www.games-workshop.com/communi...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-10 19:30 PDT by James
Modified: 2008-07-31 01:51 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description James 2003-10-10 19:30:05 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Small bug...

In the url I gave you, I have an account. Mozilla is storing the subject for my
posts as well as the password and username. So when I enter a new subject in, it
asks if I want to create a new identity.

Reproducible: Always

Steps to Reproduce:
1. Create an account for the forum(works on all the forums).
2. Post a message and choose a subject.
3. Post a new message 
4. Mozilla will automatically fill in the User/Password/Subject.
5. Choose a new subject
6. Mozilla will ask you if you want to save the new User/Password/Subject.

Actual Results:  
Mozilla stores subject as well as password and account. Asks everytime if I want
to save new identity.

Expected Results:  
I don't think Mozilla should store subject...
Comment 1 Matthias Versen [:Matti] 2003-10-10 19:36:48 PDT
Can you reproduce that with Mozilla or only with Firebird ?
Comment 2 James 2003-10-10 19:46:46 PDT
Don't have normal Mozilla... only Firebird.
Comment 3 Bill Mason 2003-10-10 19:49:06 PDT
This may be the Firebird form autocomplete bug 199819.  The partial fixes for
that bug postdate the 0.6.1 milestone.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2003-10-10 20:09:52 PDT
If you don't have normal Mozilla to test with, please file UI-related bugs on
the right product.
Comment 5 alanjstr 2003-10-10 20:59:19 PDT
I can confirm that a problem used to exist.  It happened to me on the Talkback
on MozillaZine.  But a lot of things have changed since then, so this may not
still be a bug.
Comment 6 David P James 2003-10-10 21:02:52 PDT
Password manager has been changed since 0.6.1. Could you try this with a newer
build and a new profile? (one of the 0.7 release candidates or 0.7 once it's out)
Comment 7 Steffen Wilberg 2003-10-17 14:19:19 PDT
Moving to the new password manager component and reassigning.
Comment 8 Jesse Ruderman 2003-10-19 15:52:12 PDT

*** This bug has been marked as a duplicate of 153986 ***
Comment 9 David P James 2003-12-14 17:33:16 PST
v.

Note You need to log in before you can comment on or make changes to this bug.