New Feature: Browser should automagically identify mail addresses & provide link.

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
15 years ago
15 years ago

People

(Reporter: kickthedonkey, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686) Gecko/20030311 Galeon/1.3.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030311 Galeon/1.3.3

When the Browser paser encounters a real-world geographical address, it would be
nice if it made that address text linkable to the users mapping website of
choice (maps.yahoo.com, mapquest.com, etc).  Possible identifiers for for a map
link are:  

     -a 'map' icon is inserted next to the text
     -becomes a link of a different color...
The idea here is to make it easier for the users to find real locations, with
out having to cut'n'paste the address to a new tab/window.

This should be an option that could be enabled/disabled based upon user preference.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
although I agree it can be nice, Mozilla has too many feature requests, let's
make this an extension project on mozdev.org instead.

Similar projects:
http://messageidfinder.mozdev.org/
http://gemal.dk/mozilla/linky.html

Propose to resolve WONTFIX.
(Reporter)

Comment 2

15 years ago
Sounds alright to me.  After looking over the Linky src code, it looks like my
idea can be added to that (or, atleast adapted from that)...

If my input means anything, go ahead and resolve it as 'WONTFIX'.

Thanks

Comment 3

15 years ago
.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.