Closed Bug 222042 Opened 21 years ago Closed 21 years ago

mail compose window zlevel is unconstrained

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.6alpha

People

(Reporter: danm.moz, Assigned: danm.moz)

Details

Attachments

(1 file)

The Mail Compose window, with a normal z-level, is allowed to drop behind an
alwaysLowered browser window. (Bad).

Current trunk build.
0) Install the window z-level altering extension from bug 42557.
   (Heh. A little bit of advertising, there.)
1) Launch Mozilla (I'm assuming it opens a browser window by default).
2) Set the browser window's level to "lowered."
3) Open the Mail & Newsgroups window.
4) Open a new Message window.
5) Close the Message window from step 4.
6) Open another "new" Message window.
   (operational note: it's really the same window).
7) Mouseclick the browser window.
   -- the Message window is sent behind the browser window.

This may be related in some way to bug 204761 (which I can't reproduce). This
bug, though, is specific to the Mail Compose window. That window isn't actually
deleted when it's "closed"; it's only hidden. This bug is related to the Compose
window's unique close/reopen methodology.
Registering the window before showing it can only be a good thing. But actually
I'm surprised this fixes the bug. I was seeing scary stuff at the widget level
that made it seem a lot harder. Still, this does the trick...

Note the change to nsWindowMediator isn't strictly necessary: that error wasn't
being triggered. But the extra check seems like a good idea. It'd be very
confusing to register one window twice.
Attachment #133215 - Flags: review?(scott)
Status: NEW → ASSIGNED
PS -- in the steps to reproduce, nos. 4 and 6, I opened the Compose Message
window by clicking the "Compose" button in the Mail & Newsgroups window, not by
making a menu selection from the browser window. That's probably important.
Attachment #133215 - Flags: review?(scott) → review+
Attachment #133215 - Flags: superreview?(sspitzer)
Comment on attachment 133215 [details] [diff] [review]
register compose window before showing it

sr=sspitzer, assuming the cached compose window still works.
Attachment #133215 - Flags: superreview?(sspitzer) → superreview+
Seems to! On Windows, at least. Patch is checked in to the trunk.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.6alpha
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: