[RFE] Ability to create a fake reject message (e.g. unknown user) for the currently selected mail

VERIFIED DUPLICATE of bug 109930

Status

MailNews Core
Composition
--
enhancement
VERIFIED DUPLICATE of bug 109930
14 years ago
9 years ago

People

(Reporter: Markus Fischer, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

A new feature to send a message to the sender of the currently selected
messages, faking a mailer-daemon delivery status message.

This is a convinient way to try to let the sender know that the mailbox is not
avialable (although it is).

Thoughts:
The feature would reside in the menu "Message" as "Reject". Upon activating, it
will start up the composer with:
1. a pre-made delivary-status message (multipart/report with text/plain,
message/delivery-status and text/rfc822-headers parts)
2. the the To: field filled out with the return path

The content of the message would be any like the popular sendmail default
message, like

"The original message was received at <date of the received message> from
mail.xyz.com

 ---- The following addresses permanent fatal errors ----
myaccount@mydomain.com

 ---- Transcript of session follows ----
myaccount: Mailbox does not exist
550 <myaccount@mydomain.com>... User unknown"

This part should be from a template, a default one like this shipped with
mozilla; but exchangeable by the user (just like signatures). The other parts
should be reassembled to make the remote end think this user is what the
messages says: unknown.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

14 years ago
Summary: Ability to create a fake reject message (e.g. unknown user) for the currently selected mail → [RFE] Ability to create a fake reject message (e.g. unknown user) for the currently selected mail

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 12916 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 109330 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 109930 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.