Build problems using MSVC++ 6, syntax error during idl compile

RESOLVED WORKSFORME

Status

SeaMonkey
Build Config
--
major
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Mats Lundquist, Assigned: Chase Phillips)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: mozilla-source-1.4.tar.gz

Syntax error during idl compiling, see below...

make[5]: Entering directory 
`/cygdrive/d/utv/mozilla/embedding/browser/activex/src'
make[6]: Entering directory 
`/cygdrive/d/utv/mozilla/embedding/browser/activex/src/control'
sh /cygdrive/d/utv/mozilla/build/cygwin-wrapper -up /usr/bin/perl -
Id:/utv/mozilla/config d:/utv/mozilla/config/build-li
/config/final-link-libs mozctl
"midl" /Oicf /h MozillaControl.h /iid MozillaControl_i.c 
d:/utv/mozilla/embedding/browser/activex/src/control/MozillaCon
Microsoft (R) MIDL Compiler Version 5.01.0164
Copyright (c) Microsoft Corp 1991-1997. All rights reserved.
Processing 
d:\utv\mozilla\embedding\browser\activex\src\control\MozillaControl.idl
MozillaControl.idl
Processing D:\utv\ms\VC98\include\oaidl.idl
oaidl.idl
Processing D:\utv\ms\VC98\include\objidl.idl
objidl.idl
Processing D:\utv\ms\VC98\include\unknwn.idl
unknwn.idl
Processing D:\utv\ms\VC98\include\wtypes.idl
wtypes.idl
Processing D:\utv\ms\VC98\include\ocidl.idl
ocidl.idl
Processing D:\utv\ms\VC98\include\oleidl.idl
oleidl.idl
Processing D:\utv\ms\VC98\include\servprov.idl
servprov.idl
Processing D:\utv\ms\VC98\include\urlmon.idl
urlmon.idl
Processing D:\utv\ms\VC98\include\msxml.idl
msxml.idl
D:\utv\ms\VC98\include\urlmon.idl(486) : error MIDL2025 : syntax error : 
expecting a type specification near "DWORD"
D:\utv\ms\VC98\include\urlmon.idl(487) : error MIDL2026 : cannot recover from 
earlier syntax errors; aborting compilatio
make[6]: *** [done_gen] Error 234
make[6]: Leaving directory 
`/cygdrive/d/utv/mozilla/embedding/browser/activex/src/control'
make[5]: *** [export] Error 2
make[5]: Leaving directory 
`/cygdrive/d/utv/mozilla/embedding/browser/activex/src'
make[4]: *** [export] Error 2
make[4]: Leaving directory `/cygdrive/d/utv/mozilla/embedding/browser'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/cygdrive/d/utv/mozilla/embedding'
make[2]: *** [tier_9] Error 2
make[2]: Leaving directory `/cygdrive/d/utv/mozilla'

Reproducible: Always

Steps to Reproduce:
1. Followed http://mozilla.org/build/win32.html instructions
2. Using MSVC++ 6 with SP5 and Processor Pack
3. Using mozilla-source-1.4.tar.gz

Comment 1

14 years ago
can you try again with 1.5 ?
Assignee: general → leaf
Component: Browser-General → Build Config
(Reporter)

Comment 2

14 years ago
Same problem with 1.5a and 1.5b
Severity: blocker → major
Sounds like a problem with the activex control....

Comment 4

14 years ago
There is no problem that I am aware of. Please check that you have SP5 installed
and your paths correctly configured. Unpatched MSVC++ definitely has som COM
problems.
(Reporter)

Comment 5

14 years ago
I have removed and reinstalled cygwin and MSVC++ SP5. The compilation still 
gives the same result.

Updated

13 years ago
Assignee: leaf → cmp
Product: Browser → Seamonkey
wfm with MSVC6 SP% since months
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.