"disable-output-escaping"-attribute in xsl:text-element is ignored

RESOLVED DUPLICATE of bug 98168

Status

()

RESOLVED DUPLICATE of bug 98168
15 years ago
15 years ago

People

(Reporter: berg.christian, Assigned: peterv)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

The content of an xsl:text element is still html-escaped, even if the
disable-output-escaping="yes" attribute is set. Example:

<xsl:text disable-output-escaping="yes">&amp;copy;</xsl:text>

produces &copy; in the generated html instead of the wanted copyright symbol. I
think this is a bug, at least it works in IE...

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
disable-output-escaping is an attribute to control how output (=serialization)
works. However since XSLT in mozilla doesn't do serialize it has no effect. 

d-o-e is also an optional feature of XSLT that you shouldn't rely on unless
absolutly neccesary, which it isn't here.

<xsl:text disable-output-escaping="yes">&amp;copy;</xsl:text>

is much easier written as

&#169;

Read the duplicated bug

*** This bug has been marked as a duplicate of 98168 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.