block unrequested popup windows has regressed and no longer functions properly

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Peter Kroll, Unassigned)

Tracking

Trunk
x86
Windows XP
Bug Flags:
blocking1.6a -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

If you visit http://www.kevscelebs.com (warning adult site) and click link #1 in
the top 10 the link which is supposed to open in a new window will be blocked.
You will have to click it 3 times to get the window to open.
Clicking a link is requesting the window, it should not be block and was not
blocked in version 1.4

I have found another example at:
http://www.carpetheritage.net
You must login to view the images, username: abe password: 100
After logging in when you click a thumbnail the new window gets blocked. I had
to click multiple times for the window to be opened. This is not correct behavior.

on kevscelebs.com the new window is being opened using target="_blank" on
carpetheritage.net it's using window.open

The functionality of 1.5 is majorly broken and this should be a stop shipment
while the problem is fixed.


Reproducible: Always

Steps to Reproduce:
1. Please see details.
2.
3.

Actual Results:  
new window is blocked when link is clicked

Expected Results:  
new window should open when link is clicked
(Reporter)

Updated

15 years ago
Flags: blocking1.5?

Updated

15 years ago
Flags: blocking1.5?
(Reporter)

Updated

15 years ago
Flags: blocking1.6a?

Updated

15 years ago
Flags: blocking1.6a? → blocking1.6a-

Comment 1

15 years ago
I've just tested both on build 2003110115 on Windows XP (This is the Mozilla
1.6a release)... both work fine.

Comment 2

15 years ago
I've just tested both on build 2003110115 on Windows XP (This is the Mozilla
1.6a release) and I still have the exact same problem which is reproducible 100%
of the time. All new windows are blocked when a link is clicked and they are not
pop ups, they are links trying to open in the target _blank

Comment 3

15 years ago
I think there is another issue here. I've tried the 1.6a release on my Mac OSX
10.2.8 machine as well... and that is working fine. My Windows machine continues
to perform perfectly as well. I've confirmed that the blocker IS working (and
not just for some reason allowing everything through) by going to
www.aintitcool.com and www.msnbc.com. Both show the icon indicating a popup was
blocked.

Comment 4

15 years ago
Following your lead I installed 1.6a on a totally different computer that had
1.4 previously installed instead of 1.5 and the exact same thing happens when
the pop up blocker is turned on. Mozilla 1.6a on Windows XP Pro in both cases.
(Reporter)

Comment 5

15 years ago
I must stress there definitely is a bug here somewhere. My steps to reproduce
may not be entirely accurate.
If you are upgrading versions make sure to keep the same profile.
carpetheritage.net has been recently modified, so it may not be as accurate for
testing.
If you go to kevscelebs.com, attempt to click one of the top 10 links while the
site is loading. That still blocks the new site from opening.

I am having trouble reproducing my original bug where you have to click multiple
times to get the bug to open. To reproduce it you may have to install mozilla
1.4 set the popup blocker to block popups then install mozilla 1.5 over it, use
the same profile and then try the steps in the first post.
(Reporter)

Comment 6

15 years ago
"If you go to kevscelebs.com, attempt to click one of the top 10 links while the
site is loading. That still blocks the new site from opening."
-I tried this in 1.6a

"I am having trouble reproducing my original bug where you have to click multiple
times to get the bug to open."
-I'm having trouble reproducing this in 1.5 and 1.6a but I know it is there for
sure in 1.5, please try my steps in the previous post to reproduce this.

Comment 7

15 years ago
uninstalled the program deleted the mozilla directory, deleted the mozilla
directory in the application data directory installed 1.6a in a directory called
1.6a and it is still blocking requested windows.

Comment 8

15 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031206

Works for me. All clicks on www.kevscelebs.com open in the original window
(rather than a new window or tab).

My blocker preferences are:

Prefs | Privacy & Security | Popup Windows 
  x Block unrequested popup windows
  x Display an icon in the Navigator status bar

Prefs | Advanced | Scripts & Plugins
  Allow scripts to:
  x Change images
  (all others are unchecked)

Comment 9

15 years ago
Dupe of bug 101190?

Comment 10

14 years ago

*** This bug has been marked as a duplicate of 101190 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 11

14 years ago
this bug is not a duplicate of 101190.

the original comment deals with the windows not opening AFTER the page has
loaded. The comments about not opening windows during loading is infact a
seperate bug, bug 101190.

But this is definitely a seperate issue.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 12

14 years ago
Both sites WFM using Mozilla 1.8a4 on Windows XP SP2. Please re-open if you
still see this bug using a recent trunk build. Also, note that you should
uninstall before installing a new version -- this will not delete your profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.