Choosing Mozilla as default browser causes multiple file types to be hijacked.

VERIFIED DUPLICATE of bug 131106

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 131106
14 years ago
13 years ago

People

(Reporter: Craig Rae, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

When Mozilla is started, by default it checks to see if it is the default
browser. If not, a dialogue box is displayed asking the user if they would like
to make Mozilla their default browser, with 3 buttons - "Yes", "No" and "Cancel".

Pressing "Yes" sets Mozilla as the default browser as expected. However, it does
much more than just that, some of which is completely unacceptable.

After pressing "Yes", Mozilla modifies the file type for HTML files to be opened
by Mozilla by default. That's reasonable, and is expected behaviour.

However, what is unreasonable and unexpected is for Mozilla to hijack other file
types so that they are also opened by Mozilla by default. These include both GIF
and JPEG images.

Just because I install Mozilla and use it as my default browser, what makes you
think I want it to open all of my images by default, too? If I already have them
set up so that they're opened by an image editor (for example), don't you think
that I might continue to want them to be opened by that editor by default rather
than my web browser.

This needs to be fixed. I moved to Moz to get away from B.S. like this. I now
have to go back through the affected file types and undo this nonsense by hand.

Reproducible: Always

Steps to Reproduce:
1. If Moz is your default browser, set your defualt to something else.
2. Ensure that GIF and JPG images are set to be opened by another program. For
the full effect, leave a folder full of images open and visible in large icon view.
3. Run Mozilla. You will be presented with a dialoge that asks if you want to
make Moz your default browser.
4. Choose "Yes" on the dialogue. Recoil in horror as the thumbnails for your
images are suddenly transformed into a seea of Orange dinosaurs. :)

Actual Results:  
Moz hijacks various other file types.

Expected Results:  
Moz shouldn't touch other file types. The user giving permission for Moz to set
itself as the default browser does not equate to permission to go grab a bunch
of other stuff.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 131106 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Verified, and moving to XP-Apps. 
Status: RESOLVED → VERIFIED
Component: Browser-General → XP Apps
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.