bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Allow site-specific preferences?

RESOLVED DUPLICATE of bug 38966

Status

SeaMonkey
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 38966
15 years ago
5 years ago

People

(Reporter: thesh_bugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007

Would it be possible to have site-specific preferences sometime in the future? I
realize that this may be difficult to do, but I would like to have the ability
to set my preferences a certain way on one site to over-ride the default
preferences. For example, the only site that I want to allow javascript to move
or re-size windows is the site I visit more often than any other. I don't like
other websites to do this, as i find it annoying. What I would like to do is set
the preferences to disable this on most sites, but then when visit that website
be able to over-ride any preferences that I want without having to change them
every time. There are other things as well, like not allowing some websites to
animate images or load third party images, while allowing this for others. You
should have the ability to change pretty much anything that would be relevant in
the preferences page i.e. you don't need themes, anything to do with composer
and mail, history, proxy, system, etc. However, a site-specific cache might be a
useful thing to include with this. In other words, a sperate cache folder where
the cache is read/write only when browsing that site, and read only when
browsing any other site.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
Sorry, forgot to put this under preferences...
Component: Browser-General → Preferences

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 38966 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.