Opening pdf using Acrobat 5.0.8 plugin causes firebird to crash

RESOLVED DUPLICATE of bug 219987

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 219987
14 years ago
14 years ago

People

(Reporter: uvr, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5) Gecko/20031016 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5) Gecko/20031016 Firebird/0.7

When I try to open a[ny] pdf file in firebird using the Acrobat 5.0.8 
plugin (latest available plugin for Solaris), the acroread app is 
correctly launched (splash screen appears) and shows the successful
loading of all components.  Then, just as the file is about to be
displayed inside the firebird window, the browser crashes.

This behavior is observed regardless of whether (a) the plugin is
present in the ${Firebird_Installation_Dir}/plugins directory, or
(b) located in a separate directory pointed to by MOZ_PLUGIN_PATH.

The crash is also observed on Firebird 0.6 and 0.6.1.  However, the
same plugin (same nppdf.so file) successfully opens pdf files when
used with Mozilla 1.3.1, 1.4, 1.5rc2 and 1.5.

Reproducible: Always

Steps to Reproduce:
1. Launch Firebird (0.6, 0.6.1 or 0.7)
2. Browse to a page that contains a link to a[ny] PDF file.
3. Click on the link.  Observe that the Acroread flash screen shows
   up and displays component loading progress.
4. Observe that the display on the splash screen stop momentarily and
   Firebird crashes.
Actual Results:  
Firebird crashed.

Expected Results:  
Firebird should not have crashed.  It should have displayed the file
just as Mozilla 1.x does.
(Reporter)

Comment 1

14 years ago
Ok, so here is a workaround (d'oh, I should have figured this out earlier).

The error which occurs just before firebird crashes is the following


ld.so.1: /opt/MozillaFirebird/MozillaFirebird-bin: fatal: relocation
error: file /opt/MozillaFirebird/plugins/nppdf.so: symbol
XmProcessTraversal: referenced symbol not found
Killed

I'm not sure why it can't find XmProcessTraversal.  It's in /usr/lib/libXm.so

So, anyway, I tried to add /usr/lib to the head of my LD_LIBRARY_PATH,
foolishly assuming that doing so would cure this malady.  No luck.

What did work, was this:

$ export LD_PRELOAD=libXm.so
$ MozillaFirebird

And PDF files now open just as well as they do in Mozilla.

FWIW, "about:buildconfig" reports that my copy of firebird was build with
the following configure arguments:

--enable-crypto --enable-ctl --enable-xinerama --enable-x11-shm
--enable-extensions=default,-irc,-venkman,-inspector,-content-packs,-help
--enable-plaintext-editor-only --enable-xterm-updates --enable-js-ultrasparc
--enable-static --enable-strip --enable-strip-libs --disable-shared
--disable-mailnews --disable-composer --disable-tests --disable-debug
--disable-logging --disable-ldap --disable-xprint --without-xprint
--without-system-nspr --without-system-zlib --without-system-jpeg
--without-system-mng --without-system-png 

Comment 2

14 years ago
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7
Have the nearly the same behaviour with one installation of Firebird 0.7 on
Windows XP:

When opening a PDF-file, Acrobat starts loading all plugins, and when finished,
Acrobat doesn't come up with the documanet and Firebird freezes consuming all
CPU power it can. Firebirld has to be killed through Taskmanger.

Acrobat Plugin is     
File name: nppdf32.dll
Adobe Acrobat Plug-In Version 5.10 for Netscape

Note: This happens only in this particular installation. On other machines
everything works fine. 

Steps to Reproduce:
1. Like Bug 222708. Exact preconditions unknown. 
Actual Results:  
Firebird freezes, consuming all CPU. Document not shown.

Expected Results:  
Firebird should not freeze. Acrobat should display PDF-file.

Comment 3

14 years ago
Bug 219987 seems to be a newer version of this bug.  I'm marking a dupe.  If you
feel this is incorrect, please feel free to reopen.

*** This bug has been marked as a duplicate of 219987 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.