Scrollbar in frame is misproportioned and missing down arrow

RESOLVED DUPLICATE of bug 88035

Status

()

Core
Layout: HTML Frames
RESOLVED DUPLICATE of bug 88035
15 years ago
15 years ago

People

(Reporter: George Kennedy, Unassigned)

Tracking

1.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

At the abobe url on the left hand frame click on advisory circulars-current
acs-by number.  In the right hand frame you will get a large list of advisory
circulars with a scrollbar.  However the movable part of the scrollbar takes up
the entire screen and is missing the down arrow on the bottom.  By comparison
when this page is loaded up in IE6 you can scroll down quite a bit.  In firebird
the whole frame seems to just disappear under the status bar but there is no way
to scroll down.

Reproducible: Always

Steps to Reproduce:
1.Load url above in firebird
2.On left hand menu navigate to Current AC's by Number
3.



Expected Results:  
Should be able to scroll down and see the rest of the page

Comment 1

15 years ago
Firebird does not lay out the frames, this bug belongs in browser.

I see this in Linux Gecko/20031007 Firebird/0.7 and mozilla 1.4.1
Assignee: blake → frame
Status: UNCONFIRMED → NEW
Component: General → Layout: HTML Frames
Ever confirmed: true
Product: Firebird → Browser
Version: unspecified → 1.0 Branch
The problem is an overflow:auto height:100% div... there is no reason for it to
have a scrollbar, since it doesn't overflow, since it gets an auto height.

Fixed in current builds by the checkin for bug 222730

*** This bug has been marked as a duplicate of 88035 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
I just checked this in the nightly build of Mozilla (Mozilla/5.0 (Windows; U;
Windows NT 5.0; en-US; rv:1.6a) Gecko/20031020) and while it is much better it
is still not quite right.  Take a look at the url again.  Now you definately can
scroll it but it seems like there should still be an arrow on the bottom of the
scroll bar.  
Nope.  With the way the markup is done, the <div> with the scrollbar is in fact
taller than the space alotted for it.  So the arrow is there, just off the
bottom of the non-scrollable frame.
You need to log in before you can comment on or make changes to this bug.