compile time error, trying to compile Composer standalone on Mac OS X

RESOLVED EXPIRED

Status

SeaMonkey
Composer
--
major
RESOLVED EXPIRED
15 years ago
8 years ago

People

(Reporter: Bjarne D Mathiesen, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
mkdir -p ../../dist/Composer.app/Contents/MacOS
rsync -a ./macbuild/Contents ../../dist/Composer.app
link_stat ./macbuild/Contents : No such file or directory
rsync error: partial transfer (code 23) at
/SourceCache/rsync/rsync-8/rsync/main.c(576)
Marking invalid due to lack of information.  Please reopen when you can provide
something that would let us address this.  Exactly what source you're trying to
build and the commands you're using would be a good start.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Summary: compile time error → compile time error
(Reporter)

Comment 2

15 years ago
I'm trying to compile Composer standalone on Mac OS X
I've followed the instructions as provided by 
http://lxr.mozilla.org/mozilla/source/composer/readme.html
http://www.mozilla.org/build/unix.html

mozconfig:
ac_add_options --enable-default-toolkit=mac
ac_add_options --enable-crypto
ac_add_options --disable-debug
ac_add_options --enable-optimize=-O2
ac_add_options --disable-ldap
ac_add_options --disable-mailnews
ac_add_options --disable-mathml
ac_add_options --disable-installer
ac_add_options --disable-activex
ac_add_options --disable-activex-scripting
ac_add_options --disable-tests
ac_add_options --disable-oji
ac_add_options --disable-necko-disk-cache
ac_add_options --disable-profilesharing
ac_add_options
--enable-extensions=cookie,xml-rpc,xmlextras,pref,universalchardet,webservices
ac_add_options --without-system-nspr
ac_add_options --without-system-zlib
ac_add_options --without-system-jpeg
ac_add_options --without-system-png
ac_add_options --without-system-mng

ac_add_options --enable-image-decoders=icon,png,gif,jpeg

export MOZ_STANDALONE_COMPOSER=1
mk_add_options MOZ_STANDALONE_COMPOSER=1

commands:
cvs co -f mozilla/client.mk
cp mozconfig mozilla/.mozconfig
cd mozilla
make -f client.mk

Seems to me it fails when trying to make the mac distribution
Seems as if there's a missing . in 
is:         rsync -a ./macbuild/Contents ../../dist/Composer.app
should be : rsync -a ../macbuild/Contents ../../dist/Composer.app

The original report is the last few lines of the make output.
I can provide more lines if neccessary
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Thanks.  Over to glazou.
Assignee: composer → daniel
Status: REOPENED → NEW
Right. Mac build untested yet, I have no mac here...
Status: NEW → ASSIGNED
(Reporter)

Comment 5

15 years ago
I'll gladly provide the testing on Mac OS X :-)

I'm already doing that for Calender & SunBird as well as SVG;
and I'm helping bsmedberg with bug 20640 under Mac OS X

http://mozilla.mathiesen.info/
(Reporter)

Comment 6

15 years ago
some further information:
I split 'make -f client.mk' into './configure , make , sudo make install' and
ran them on top of the partial build I had.

'./configure' no apparent problem

'make -w' fails with :
make[4]: Leaving directory `/Volumes/swap/Composer/mozilla/composer/app/profile'
../../config/nsinstall -L /Volumes/swap/Composer/mozilla/composer/app
editorWindow.xpm editorWindow16.xpm ../../dist/bin/chrome/icons/default
mkdir -p ../../dist/Composer.app/Contents/MacOS
rsync -a ./macbuild/Contents ../../dist/Composer.app
link_stat ./macbuild/Contents : No such file or directory
rsync error: partial transfer (code 23) at
/SourceCache/rsync/rsync-8/rsync/main.c(576)
make[3]: *** [libs] Error 23
make[3]: Leaving directory `/Volumes/swap/Composer/mozilla/composer/app'
make[2]: *** [libs] Error 2
make[2]: Leaving directory `/Volumes/swap/Composer/mozilla/composer'

Comment 7

15 years ago
Not a blocker by definition.
Severity: blocker → major
Product: Browser → Seamonkey
Assignee: daniel → nobody
Status: ASSIGNED → NEW
QA Contact: composer
Summary: compile time error → compile time error, trying to compile Composer standalone on Mac OS X

Comment 8

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 9

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago8 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.