Password manager prompts to remember empty logons

VERIFIED DUPLICATE of bug 217439

Status

()

Toolkit
Password Manager
VERIFIED DUPLICATE of bug 217439
14 years ago
9 years ago

People

(Reporter: Anthony Meehan, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

If a form is submitted with a blank username and password, the password manager
still prompts to store the logon.

An example of this is a site which has a 'Register Now' button within the same form.

Reproducible: Always

Steps to Reproduce:
1. Create a form which has username and password fields
2. Add two submit buttons (eg Login and Register)
3. View the form, and click the 'Register' button.

Actual Results:  
The 'Password Manager' prompt appears, asking if you wish to save the logon details.

Expected Results:  
The form should just submit, since no username or password values were entered.
(Reporter)

Comment 1

14 years ago
Created attachment 133759 [details]
Testcase

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 217439 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
v.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.