[Win32] Menu items disappear behind taskbar

VERIFIED DUPLICATE of bug 21154

Status

()

P4
normal
VERIFIED DUPLICATE of bug 21154
19 years ago
19 years ago

People

(Reporter: BenB, Assigned: mikepinkerton)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Menus end at the screen boundaries, however the task bar isn't recognized, so
the last item(s) disappear behind it.

Proposed fix: alter the code, that determines and reports the boundaries of the
screen, from reporting the real monitor boundaries to reporting the boundaries
of the currently visible (to honor multiple monitors or vitual desktops) and for
applications available space.
(Reporter)

Updated

19 years ago
Summary: "Screen" excludes Taskbar → [Win32] "Screen" excludes Taskbar
(Reporter)

Comment 1

19 years ago
Win32

Updated

19 years ago
Assignee: trudelle → saari
Priority: P3 → P4
Target Milestone: M14

Comment 2

19 years ago
reassigning to saari as p4 for m14, cc hyatt

Comment 3

19 years ago
Dan, does changing what the DOM screen reports as its size sound like the right way to go about this? Does the DOM spec even address this?

Comment 4

19 years ago
You don't really want to mess with the basic screen size, since some parts of the code
(JS, for instance) need to know both. See the distinction between screen.width and
screen.availWidth: one is actual size, the other is useable, client size (minus things
like system toolbars and the Mac menubar). Sounds like you just need the "avail"
numbers. These are things theoretically already tracked by the DOM screen object
and by gfx device contexts, if you can get to one of them from wherever you are.
(Reporter)

Updated

19 years ago
Summary: [Win32] "Screen" excludes Taskbar → [Win32] Menu items disappear behind taskbar
(Reporter)

Comment 5

19 years ago
Good. Withdrawing proposed fix :-) and changing summary from "[Win32] "Screen"
excludes Taskbar" to "[Win32] Menu items disappear behind taskbar".

Updated

19 years ago
Assignee: saari → sdagley

Comment 6

19 years ago
GetAvailWidth and GetAvailHeight *are* what is being called. Next theory please.

Oh yeah, I'm giving this to Dagley. Steve, nsMenuPopupFrame::SyncViewWithFrame
is the place where all this positioning happens.

Updated

19 years ago
QA Contact: paulmac → sairuh

Comment 7

19 years ago
Passing the menu bug torch to pinkerton
Assignee: sdagley → pinkerton
(Assignee)

Comment 8

19 years ago


*** This bug has been marked as a duplicate of 21154 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 9

19 years ago
Verified dupe of 21154
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.