If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wrong threading of independent messages with equal headers.

RESOLVED DUPLICATE of bug 164115

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 164115
14 years ago
13 years ago

People

(Reporter: Constantin Stefanov, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME:WONTFIX/INVALID)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

When two independent messages (having no references to each other, for example,
made by pressing 'Compose' in Mozilla) with equal headers are viewed in mode
'Display message threads', they are shown as one thread.

Reproducible: Always

Steps to Reproduce:
1. Send two independent messages to one account so they go into one folder.
2. Click on the icon which has 'Click to display message threads' popup.

Actual Results:  
Both messages are shown as they are in the same thread.

Expected Results:  
Messages should make two different threads

I will post two expamle messages and a screenshot of what I see.
(Reporter)

Comment 1

14 years ago
Created attachment 133825 [details]
The first of two messages.
(Reporter)

Comment 2

14 years ago
Created attachment 133826 [details]
The second of two messages.
(Reporter)

Comment 3

14 years ago
Created attachment 133827 [details]
Screenshot of message pane.

A thread of two messages in previous attachments is seen. They should make two
threads.

Comment 4

14 years ago
All you need are two messages with the same subject. IMO it's a feature.

The simplest example is Bugzilla Bugmail. Each of the emails for this bug
(ignoring the original and any requests) have the same subject (until you change
it), so they'll be grouped as a thread. The bugmails don't have internal
threading headers, so this is the only way for any email app to make them into a
thread.
Whiteboard: DUPEME:WONTFIX/INVALID

Comment 5

14 years ago
Dupe 164115

*** This bug has been marked as a duplicate of 164115 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.