Closed Bug 223314 Opened 17 years ago Closed 17 years ago

Browser should indicate it's porting IE bookmarks on first startup of new profile

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 240136

People

(Reporter: e_gravel, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Firebird appears to freeze the first time it's started for a new profile. This
was traced to the automatic import of IE favorites, WHILE it's trying to load
the mozilla.org page. The apparent freeze takes much longer the more IE
favorites there are to import.

Reproducible: Always

Steps to Reproduce:
1.Make sure you have many IE Favorites
2.Create a new profile
3.Start Firebird
Actual Results:  
Firebird seems to freeze while attempting to load the mozilla.org page.

Expected Results:  
This should have been a two-step process. First, Firebird should have asked if
the user wanted his IE favorites imported. If yes, then there should have been
some kind of a progress bar indicating that the bookmarks are being imported.
After that, the start page should load.

*** This bug has been marked as a duplicate of 240136 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.