Closed Bug 223334 Opened 21 years ago Closed 21 years ago

Group of Tabs Bookmark load overwrites existing web sites being viewed

Categories

(SeaMonkey :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 208278

People

(Reporter: tdemers, Assigned: p_ch)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

When I load a "Group of Tabs" Bookmark it removes all other web pages being
viewed. For example, if I have 3 tabs open - google.com, dictionary.com and
yahoo.com then I decide to load a group of weather sites, it removes the above 3
(or however many *were* open) and replaces it with the 3 I have in my weather pages.
This happened in 1.5RC2 and I figured someone would have seen it and reported it...
I thought maybe the bookmark entry was bad, so I created a new one. Same problem.

This was a bit frustrating the first few times, because I had 7-8 other tabs
open, and lost all the sites I was viewing. I have learned to be more careful,
but it would be nice if this was fixed... Worked great in 1.4 and prior.


Reproducible: Always

Steps to Reproduce:
1. Open Mozilla and open a few pages in "tabbed view"
2. Create a "Group of Tabs" bookmark entry with at least 2 web sites (I did
google.com and yahoo.com)
3. Select 2 different web sites (doesn't matter)
4. Use the bookmarked "Group of Tabs" link to open those pages.
Actual Results:  
The originally loaded pages disappear!

Expected Results:  
In versions 1.4 and prior, the new tabs would load in the current window, and
all "old" tabs remained.

Using default theme. Any other info should be basic. No crash occurs.
System config is standard Windows XP Pro running latest Service Packs (SP1) with
all hotfixes applied.
Thanks to Hermann Schwab for the comment:
There is now a pref to get the old behaviour back:
Edit->Preferences->Navigator->Tabbed Browsing
When opening a bookmark group
(x) Add tabs               (this has been the old behaviour)
( ) Replace existing tabs  (this is the new default)

*** This bug has been marked as a duplicate of 208278 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
My apologies. Should have looked at the prefs. Didn't find bug 208278 when doing
a search before submit.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.