spell checker improperly handles length changes in replaced words

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Jason House, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

Notice how in the reproduce steps, you're effectively adding two letters to the
word before where the problem occurs.  It appears that the scanning the
remaining text begins at 2 letters after the end of "relatity", thus skipping
the space and the letter "n".  I suspect that there is somehow a mixing of
positions in the original/corrected blocks of text...

Reproducible: Always

Steps to Reproduce:
1. compose an e-mail with a body of "relatity newsgroup"
2. start the spell check through your favorite method
3. replace "relatity" with "relativity"

Actual Results:  
the "ewsgroup" portion of "newsgroup" gets highlighted and suggests changing it
to "newsgroup"

Expected Results:  
it should not have found any other spelling errors

Comment 1

15 years ago
wild guess: fallout from the JS regexp rewrite?

Comment 2

15 years ago
if this isn't addressed by late monday i'll look at it tuesday. note that
there's a thing about null captures which was changed by the regexp landing
(correctness).
afaik, the spellchecker doesn't use js to replace words, but textservices.
http://lxr.mozilla.org/seamonkey/source/editor/txtsvc/src/nsTextServicesDocument.cpp#2256

Updated

15 years ago
QA Contact: esther → core.spelling-checker

Comment 4

14 years ago
*** Bug 229931 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Updated

10 years ago
QA Contact: spelling-checker → composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 6

9 years ago
WFM Thunderbird 2.0, Firefox 3.0.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.