Make flags show up in "View All attachments" list

RESOLVED FIXED in Bugzilla 2.18

Status

()

defect
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: dswegen, Assigned: jouni)

Tracking

({regression})

unspecified
Bugzilla 2.18
Bug Flags:
approval +
blocking2.18 +

Details

()

Attachments

(1 attachment)

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031019 Firebird/0.7+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031019 Firebird/0.7+

There is a field in the "View all" attachments page which always seems to be
blank (fourth field in the second row of each attachment, next to the attachment
date). From the code in the template (attachment/show-multiple.html.tmpl) it
would seem that this is to indicate attachment statuses (whatever they are - are
they related to flags?).

It would also seem that the vars which are used to fill the field are never
given any values in attachment.cgi.

So either this particular bit of the interface is broken, and needs fixing
(which I have no idea how to do), or it should be removed (which I probably can
do - I'm good at ripping things out ;).

Reproducible: Always

Steps to Reproduce:
1. Find a bug with attachments, and select View All
2. Observe the blank field
3.

Actual Results:  
The field always seems to be blank

Expected Results:  
Either the field should not be there at all, or it should display attachment
statuses (or 'none' if the attachment has no statuses).

This has been seen on all version of bz, from 2.17.1 to current tip

Comment 1

16 years ago
There's something fishy there, you're right. Perhaps a leftover.

I have no time to peek into this right now, but check to see if we can't easily
use the attachment flags in that space.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18
Flags: blocking2.18+
Assignee

Comment 2

15 years ago
I promised to take a look. Does anyone have an idea why this is marked as a
regression?
Assignee: myk → jouni
it's a regression because it works in 2.16.x (which had attachment statuses
instead of flags).  This particular template apparently got missed when
converting the status stuff to flags.
Assignee

Comment 4

15 years ago
Posted patch v1Splinter Review
There was no existing code for either retrieving the flags, and neither did the
flag showing code look very sensible. I don't know what's happened there, but
the patch makes it work. 

I changed the interface slightly; "statuses" is now "flags". This doesn't
really make a difference since the old approach didn't work anyway (statuses
was never set). Flags seems to be much more common terminology in existing
templates.
Assignee

Updated

15 years ago
Attachment #149619 - Flags: review?

Comment 5

15 years ago
Comment on attachment 149619 [details] [diff] [review]
v1

r=joel
(tested also)

On checkin, you might want to get rid of the extra whitespace line in
attachment.cgi
Attachment #149619 - Flags: review? → review+
Assignee

Updated

15 years ago
Status: NEW → ASSIGNED
Flags: approval?
Flags: approval? → approval+
Assignee

Comment 6

15 years ago
Extra ws killed.

Checking in attachment.cgi;
/cvsroot/mozilla/webtools/bugzilla/attachment.cgi,v  <--  attachment.cgi
new revision: 1.57; previous revision: 1.56
done
Checking in template/en/default/filterexceptions.pl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/filterexceptions.pl,v 
<--  filterexceptions.pl
new revision: 1.16; previous revision: 1.15
done
Checking in template/en/default/attachment/show-multiple.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/attachment/show-multiple.html.tmpl,v
 <--  show-multiple.html.tmpl
new revision: 1.15; previous revision: 1.14
done
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Summary: "View All" attachment statuses field empty → Make flags show up in "View All attachments" list
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.