[cookies] remove support for network.cookies.strictDomains pref

RESOLVED FIXED

Status

()

defect
--
minor
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: dwitte, Assigned: dwitte)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

16 years ago
i don't think having this pref makes sense anymore... it's been around since the
1.1 days of nsCookies.cpp, and so is _probably_ just something we can do away with.

patch coming up; there's a comment in there that explains what the pref is about...
Assignee

Updated

16 years ago
OS: Windows 3.1 → All
Assignee

Comment 1

16 years ago
Posted patch vamooseSplinter Review

Comment 2

16 years ago
i'm ok with this since it is not enabled by default... and, i presume that IE is
also loose with this check.
Assignee

Comment 3

16 years ago
Comment on attachment 134081 [details] [diff] [review]
vamoose

mvl whipped up a testcase for IE and confirmed it's loose with the check.
thanks mvl!

so, looks like this one is ready for review :)
Attachment #134081 - Flags: superreview?(darin)
Attachment #134081 - Flags: review?(darin)
Comment on attachment 134081 [details] [diff] [review]
vamoose

Please add a comment stating we don't do this check anymore. This does violate
the spec...
Assignee

Comment 5

16 years ago
sure, will do.

Comment 6

16 years ago
Comment on attachment 134081 [details] [diff] [review]
vamoose

r+sr=darin
Attachment #134081 - Flags: superreview?(darin)
Attachment #134081 - Flags: superreview+
Attachment #134081 - Flags: review?(darin)
Attachment #134081 - Flags: review+
Assignee

Comment 7

16 years ago
fixed on trunk
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.