recovering from a crash without loss of data

RESOLVED DUPLICATE of bug 19454

Status

()

enhancement
RESOLVED DUPLICATE of bug 19454
16 years ago
a month ago

People

(Reporter: boris, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.5) Gecko/20031007

When testing the Mozilla builds in a production environment it is quite
disturbing that all the data is lost.
Since the bandwidth of user input is quite low, it would be great to have an
event tracking mechanism, which records user input, so that the point before the
crash can be easily reached. (This would have to be an external app, but would
also improve the quality of bugzilla feedback significantly).
Specially when writing an e-mail or searching in the net at multiple sites it is
a pain in the neck to see it all lost.

Reproducible: Always

Steps to Reproduce:
1. doing something complicated within the mozilla suite
2. crashing mozilla
3. crying out loud because of all the work lost P-(

Actual Results:  
Data is lost and crash data is collected and sent to mozilla

Expected Results:  
Monitor the user input
Rebuild the status before the crash

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 19454 ***
Severity: critical → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.