Closed Bug 223672 Opened 16 years ago Closed 16 years ago

Direct adjacent combinators is not function when it is after :target pseudo-class

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 15608

People

(Reporter: masayuki, Assigned: dbaron)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031024
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031024

p:target+p{
    background-color: gray;
}

this style is not function.
">" and " " are fine.

Reproducible: Always

Steps to Reproduce:
1. See http://bugzilla.mozilla.gr.jp/attachment.cgi?id=1841&action=view#target

Actual Results:  
background-color of second paragraph is white.

Expected Results:  
background-color of second paragraph should be gray.

without :target
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=1841&action=view

with :target
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=1841&action=view#target

*** This bug has been marked as a duplicate of 15608 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.