DIV's positionioned incorrectly, when the contents of a div changes it's fixed height.

VERIFIED INVALID

Status

()

Core
Layout: Block and Inline
--
major
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: Kevin Ar18, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031023 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031023 Firebird/0.7+

If you set a div tag with a fixed height, and then it's contents are such that
they cause the div height to increase, this causes Mozilla to incorrectly render
other elements on the page in the wrong location.

Reproducible: Always

Steps to Reproduce:
1. Put two relative divs on a page.
2. Make the first div a fixed height of 1px
3. Put something inside that first div (such as text).

Actual Results:  
What occurs is that second div covers up the first div.  In other words, Mozilla
still thinks that the first div is 1px in height, when it has actually increased
in height due to the contents of the div.  Thus, Mozilla incorrectly positions
the second div in the wrong place (over the top of the first div).

Expected Results:  
Mozilla should have adjusted to the fact that the first div now has a new
height, and the second div should not cover up the first div.

Testcase will follow.

Marking as major, since it's critical to a project on
http://www.strategyinformer.com/  This project involves fixing non-standard code
on that site.
(Reporter)

Comment 1

15 years ago
Created attachment 134122 [details]
Simplified Testcase demonstrating problem

I will attach an example of correct rendering next.
(Reporter)

Comment 2

15 years ago
Created attachment 134123 [details]
Correct Rendering (based on IE)

Example of what I perceive to be correct rendering.  The screenshot was
obtained from IE (since it was the simplest way to make an example).
(Reporter)

Updated

15 years ago
Keywords: testcase
INVALID. IE treats height as min-height, which is wrong. Mozilla does it right.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 4

15 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.