Closed Bug 223702 Opened 17 years ago Closed 13 years ago

`decoder_source_mgr*src' might be used uninitialized in nsJPEGDecoder::Init

Categories

(Core :: ImageLib, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: timeless, Assigned: timeless)

References

()

Details

Attachments

(1 file)

84.	nsJPEGDecoder.cpp:131 (no file match) (See build log excerpt)
	`decoder_source_mgr*src' might be used uninitialized in this function

I read this as: if (mInfo.src) crash();
Attached patch patchSplinter Review
Attachment #134148 - Flags: superreview?(tor)
Attachment #134148 - Flags: review?(tor)
Is this the same as bug 134556 ?
*** Bug 134556 has been marked as a duplicate of this bug. ***
Blocks: 59652
jpeg_create_decompress() zeros out mInfo.src, so this warning doesn't really
apply.  We could just remove the test to quiet the compiler.
tor: whichever way you want, note that the second part of the patch should save
an op or two
Status: NEW → ASSIGNED
Attachment #134148 - Flags: superreview?(tor)
Attachment #134148 - Flags: superreview-
Attachment #134148 - Flags: review?(tor)
Attachment #134148 - Flags: review-
Don't we have NS_ASSERTION? What about removing the "always true" test, but
asserting that it's really true? (If we don't build for debugging, the
assertions should disappear, shouldn't they?). This seems more safely to me, and
shouldn't cost any operating time.
Fixed by Bug 325906: Remove one malloc from the JPEG decoder, and some optimizations.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.